Crash during Image Browsing [@ nsLayoutUtils::GetCrossDocParentFrame(nsIFrame const*, nsPoint*) ]

VERIFIED WORKSFORME

Status

()

Core
Layout
P2
critical
VERIFIED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({crash, topcrash})

Trunk
crash, topcrash
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta3-fixed)

Details

(Whiteboard: [wfm on 1.9.2?], crash signature, URL)

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2a1pre) Gecko/20090430 Minefield/3.6a1pre (xp x64 SP2)

Steps to reproduce:
-> Go to http://www.augustinerkeller.de/english/index.html 
-> Click on "Image Gallery" -> "Beer Garden" -> and browse through the images
--> Crash

http://crash-stats.mozilla.com/report/index/94af93ab-ea0b-4b92-8db8-561d02090430?p=1

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	nsLayoutUtils::GetCrossDocParentFrame 	layout/base/nsLayoutUtils.cpp:274
1 	xul.dll 	nsDisplayListBuilder::IsMovingFrame 	layout/base/nsDisplayList.h:191
2 	xul.dll 	AddItemsToRegion 	layout/base/nsLayoutUtils.cpp:1182
(Reporter)

Updated

9 years ago
Version: 1.9.1 Branch → Trunk
This is now the #1 topcrash on 3.6a2pre.
Severity: normal → critical
Flags: blocking1.9.2?
Keywords: topcrash
OS: Windows XP → All
Hardware: x86 → All
I'm not seeing the crash on Mac. What do you mean "browse through the images"? Just scroll up and down the frame containing images, or something else?
Tomcat, can you get a full stack from a debug build?
Flags: blocking1.9.2? → blocking1.9.2+
Priority: -- → P2
(Reporter)

Comment 4

9 years ago
(In reply to comment #3)
> Tomcat, can you get a full stack from a debug build?

hrm, thats now works for me : Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9.2a2pre) Gecko/20090810 Minefield/3.6a2pre
(Reporter)

Comment 5

9 years ago
(In reply to comment #1)
> This is now the #1 topcrash on 3.6a2pre.

hm maybe it would be worth to get the urls that have this stack signature, so i could test with my crash test automation ?
I don't see the stack anywhere in crash-stat list.
Tomcat, can you update this bug? Should we just close it?
(Reporter)

Comment 8

8 years ago
(In reply to comment #7)
> Tomcat, can you update this bug? Should we just close it?
yeah !

i'm not able to reproduce anymore, closing as wfm
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Tomcat, can you confirm that this is WORKSFORYOU on 1.9.2? (and, assuming it's fixed, set the status192 flag)

This is marked blocking1.9.2+, so we should make sure it's fixed there.
Whiteboard: [wfm on 1.9.2?]
(Reporter)

Comment 10

8 years ago
confirmed/verified wfm for 1.9.2 on beta so setting flag
Status: RESOLVED → VERIFIED
status1.9.2: --- → beta3-fixed
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsLayoutUtils::GetCrossDocParentFrame(nsIFrame const*, nsPoint*) ]
You need to log in before you can comment on or make changes to this bug.