file picker doesn't redraw dir contents after changing dir

VERIFIED FIXED in M18

Status

P4
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: bugzilla, Assigned: bryner)

Tracking

({platform-parity, regression})

Trunk
x86
Linux
platform-parity, regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+])

(Reporter)

Description

18 years ago
saw this using opt commercial bits on linux, 2000.08.14.12.

1. open file picker (alt+o, File > Open File).
2. the desplayed directory is my home dir (/u/sairuh/) --is this expected? it
used to be the installation dir...
3. anyhow, enter another dir to switch to (in my case, /u/sairuh/Tests/) by
typing the new dir in the File name textfield.
4. hit Enter key so that the dir will change and its contents redrawn in the dir
listing.

result: dir listing doesn't change --still displays the contents of my home dir.

workaround: hitting the OK button does cause the dir listing to update --but
that shouldn't be, since the OK button is what should finally open the file (as
most endusers would expect).

this is a regression, since hitting the Enter key at step 4 used to work.
(Reporter)

Comment 1

18 years ago
nominating...
Keywords: nsbeta3, pp, regression

Comment 2

18 years ago
filepicker not starting out in users home directory was a bug (41409), fix was
checked in July 30th.

Comment 3

18 years ago
->bryner, nsbeta3+, P4 for M18
Assignee: pavlov → bryner
Priority: P3 → P4
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18

Comment 4

18 years ago
Easy fix in filepicker.xul, apparantly forgotten when the great which -> keyCode
was done:

-  <textfield id="textInput" onkeypress="if (event.which == 13) { onOK(); }"
flex="1"/>
+  <textfield id="textInput" onkeypress="if (event.keyCode == 13) { onOK(); }"
flex="1"/>
(Assignee)

Comment 5

18 years ago
Yep, that does it.  Thanks for the fix.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
works fine. vrfy using 2000.08.22.08 linux comm bits.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.