Closed Bug 490914 Opened 13 years ago Closed 13 years ago

hover behavior problem if the element have title attribute

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 443178

People

(Reporter: vittorio, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; it; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10

If the user go on the NETWORK button (at the top of the page), and click it, it will show a slide menu.
It's sensible to mouse position and if the user go outside it's area, the menu will close the slide area automatically.
if the mouse goes on one of the buttons contained in the slide area, they'll work perfectly until the user wait the title attribute appear.
if it appears, and the user move the mouse again, the slide menu will close without check if the mouse still in the slide area.
i found the same problem in other buttons on other sites and give the same problem butONLY ON MAC (I'm using Leopard), in Windows and Linux doesn't have the problem.
the problem is the title attribute, if the menu doesn't contain it, will works perfectly.
you can see the problem in too many sites and in every kind of button, but the problem is serious in sensible areas, cause they drammatically close, and the user must click on buttons very fast.

Reproducible: Always

Steps to Reproduce:
1. go over a button like this: <a title="I'm the problem" href="#">Link</a>
2. wait the title appers
3. move the mouse
4. then see the bug, the title will disappear and the mouse will behave link it's outside the button for a little while
Actual Results:  
the problem is on the link hover behavior.
if the mouse go on a button and wait until title attribute appear, if the mouse moves, the link will recive a rollOut (out, outside his area) event, although it still on the button area.


Expected Results:  
the button should still on hover state and it shoudn't change until the mouse go outside it's area.

try to go on the menu buttons to see the bug and be sure to try it on a mac:
you can see how it 

http://ayozone.org/2008/02/06/drop-down-menu-with-jquery/
http://jeroencoumans.nl/journal/simple-accessible-jquery-menu
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 443178
You need to log in before you can comment on or make changes to this bug.