Homepage (current tabs) settings lost during 3.0.10 upgrade

VERIFIED WORKSFORME

Status

()

Firefox
Session Restore
--
critical
VERIFIED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Sam Pablo Kuper, Unassigned)

Tracking

({dataloss})

3.0 Branch
x86
Windows Vista
dataloss
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

Normally, when I close Firefox it asks if I want to open the same tabs next time. After the upgrade to 3.0.10, the tabs I had had open seemed to have been forgotten. This really sucks, because I hadn't bookmarked them yet and now I can't remember what they all were!

Reproducible: Always

Steps to Reproduce:
1. Open some tabs in Firefox < 3.0.10
2. Close Firefox, choosing "open these tabs again next" option (or alternatively, save those tabs as your homepage in the settings dialog)
3. Open Firefox so that it updates itself to 3.0.10
Actual Results:  
On both Vista and XP Pro, this has happened to me.

Expected Results:  
I'd expect the same tabs to be opened as I'd had open when I closed Firefox (or at least the ones from my homepage setting!).
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch
I can confirm this issue with the upgrade to Firefox 3.0.13 on Fedora 10 (GNU/Linux), so this is a cross platform issue. BTW, it happened also to me for the very last previous upgrades.

Note that I was not prompted on exit with the usual box for opening the tabs on startup though : firefox exited without saying a damn word.
http://support.mozilla.com/en-US/kb/Preferences+are+not+saved may help.
Severity: critical → major
(In reply to comment #2)
> http://support.mozilla.com/en-US/kb/Preferences+are+not+saved may help.

No, it may not. You may want to read the bug description (or the link you submitted) one more time…
Actually, it may help. If preferences are not being saved, this page me assist you to figure out why.
Component: Preferences → Session Restore
QA Contact: preferences → session.restore
Preferences are saved, it's just the last session tabs which are not (the title is indeed misleading on this point), and only after a version upgrade.

Your link is only about prefs.js and user.js problems, which are neither read-only or corrupted in this case since every other preferences are saved and since it happens only during upgrades.
Just upgraded to Firefox 3.0.14 as part of an automated complete distro (Fedora 10) update.  Before to close Firefox because it wouldn't open a thunderbird link anymore (side effect of the upgrade), I tried to save the current opened tabs as bookmarks.  I was unable to do so because the "bookmark pages" popup was blank.  Not really relevant to this bug but still relevant to the previous point, same thing happened when I tried to check the version before to close : empty popup.

As a conclusion, Firefox fails (or failed, but I seriously doubt such issues have been resolved) to correctly handle many things when a new version has been installed while the previous one is still opened.  It would not be a big problem IF there was not this history issue : I do not care about restarting firefox in the middle of my work UNDER THE CONDITION that it keeps my current tabs opened on restart (I don't care about the "firefox has been updated" page…).

PS : Can someone please mark this bug as confirmed ?  It has been happening for a bunch of versions and both for Windows and GNU/Linux, but as it happens only on upgrades one can wait for eons before someone with canconfirm rights read this by chance just before/after upgrading…

Comment 7

8 years ago
if you are wishing to stay with version 3.0, ironically, it will probably help your cause if you can show the problem also exists with v3.5 or trunk build.

you might want to test with a new profile http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
Severity: major → critical
Keywords: dataloss
Since this sounds like it's only happening on restarts, can anybody confirm that this happening following extension installs (by clicking the restart button in the extension manager).

(In reply to comment #3)
> No, it may not. You may want to read the bug description (or the link you
> submitted) one more time…

Actually it might. Session restore saves a pref indicating that it should resume your session once on startup (different from the normal startup options pref). This gets set on quit, after the dialog. Regardless, it sounds like your prefs files are fine.

I tried this on both XP & OSX with new profiles (upgrading from 3.0.9 to newest) but it worked for me. If somebody who has had this happen can reliably reproduce, that would be great. Then try with a new profile to see if there's anything special about your profile.

You can always download older versions of Firefox from the FTP site at ftp://ftp.mozilla.org/pub/firefox/releases/ Keep in mind, this is NOT a mirror, so not recommended for downloading new releases.
Just upgraded from 3.0.14 to 3.0.15, same issue.  Before to restart firefox (but after upgrading, forgot to check if firefox was in the list of packages to be upgraded), I read once more http://support.mozilla.com/en-US/kb/Preferences+are+not+saved as suggested several times, but still couldn't find any help in it.

The prefs.js is writable (-rwxr-xr-x), has not been modified during the upgrade, and has been modified during the closing of firefox.

As far as I can see, there is no way to play with profiles once the upgrade has been done, and I don't have time to play with versions right now.  BTW, symptoms mentionned in comment 6 were still present, I'm going to file a report for them as well.


Note to myself : next time, duplicate prefs.js to see how it is modified during the restart.
Skippy, are there any details about your session you can tell us?  Here are some details which can help:

1. Build ID of version you are upgrading from
2. Build ID of version you are upgrading to
3. A list of installed Add-ons/Themes and their versions
4. List of pages loaded in all open tabs and windows
5. The exact steps you are following to conduct the upgrade
6. Exact version of Fedora, Linux Kernel, and Desktop Environment you are using

I'd like to be able to replicate your environment as accurately as possible in an attempt to reproduce this bug.
I am running an up-to-date Fedora 10 with Gnome (that is, kernel 2.6.27.41-170.2.117.fc10.i686, Gnome 2.24.3 built on 16/01/2009) and Compiz running.  The current version of Firefox is Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.15) Gecko/2009102704 Fedora/3.0.15-1.fc10 Firefox/3.0.15.

Installed add-ons were at least AdBlock+, DownloadHelper, Firebug (1.05), and probably GreaseMonkey and FlashBlock.  No specific theme.  I am afraid I can't give much more information.

Comment 12

8 years ago
Skippy, so is this something you can reproduce today? that is, it happens on restarts, but not on crashes (or killing)?
Reporter, are you still seeing this issue with Firefox 3.6.13 or later in safe mode or a fresh profile? If not, please close. These links can help you in your testing.
http://support.mozilla.com/kb/Safe+Mode
http://support.mozilla.com/kb/Managing+profiles
Whiteboard: [CLOSEME 2011-2-15]
Past whiteboard date, closing.

If this still occurs, see comment 13.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → VERIFIED
Wayne : it did not happen on restarts nor on crashes, but only on upgrades.

Just upgraded from 3.6.17 to 4.0.1 through the "help > find updates" menu and it worked fine.  Note that on this computer I had to be sudo.

Comment 16

7 years ago
Skippy, thanks for the update
Resolution: INCOMPLETE → WORKSFORME
Whiteboard: [CLOSEME 2011-2-15]
You need to log in before you can comment on or make changes to this bug.