Closed Bug 49094 Opened 24 years ago Closed 24 years ago

scrollbar thumb is dragable in history dialog window

Categories

(Core :: DOM: Navigation, defect, P4)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: cmaximus, Assigned: mikepinkerton)

References

Details

(Whiteboard: [nsbeta3+][PDTP4])

***Overview Description: 

  	In hte Global History window, the scrollable thumb thinks it is dragable leading to all manner of misbehavior.

***Steps to Reproduce: 

1) Open Task|Tools|History.

2) Size your window such that you have a scrollbar.

3) Click and drag on the scrollbar thumb in an effort to scroll the view.



***Actual Results: 

	You get the drag cursor and you can drag the thumb around arbitrarily.
*As a side note, upon 'dropping' the thumb you can still scroll the view by moving the mouse. I'm assuming the fix to this bug will
correct that behavior as well. If it does not, i'll open a new bug at that time.

***Expected Results: 

	The thumb should only slide up and down.

***Build Date & Platform Info:

	Reproduced on Linux and Mac with the 2000081509 builds. Assuming Win too(XP code) but blocked by another bug there. 


***Additional Information:

	This dragable scrollbar manifested itself a while back as bug 41186 (and dupes) ther might be helpful info there.
	No, I couldn't get this to happen with any other windows.
adding nsbeta3 keyword
Keywords: nsbeta3
The same thing happens if you try to resize the columns.  Grab the column
separator and drag, you will get the d&d page icon.  Drop the icon, and you are
still dragging the separator.  This doesn't happen in other tree views (tested
with FTP).  This is Linux 2000-08-15-05.
bug 48863 describes mispaintings under FreeBSD when dragging history thumb.
I see that on linux too, and reporter of 48863 added screenshot attachment
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=12854

Since i see the same when dragging but NOT when scrolling with mousewheel,
i think 48863 can be marked dup of this bug; seems the misbehaving thumb is
causing it all.
*** Bug 48863 has been marked as a duplicate of this bug. ***
nav triage team:
nsbeta3+ because once you get caught dragging this thing, you can no longer use 
the scrollbar at all.
Whiteboard: [nsbeta3+]
Pink? If this isn't pinkerton's bug, I will at least need some help.
Whiteboard: [nsbeta3+] → [nsbeta3+] Move bug to pinkerton?
this is handled in every other window properly. it's not my bug.
Whiteboard: [nsbeta3+] Move bug to pinkerton? → [nsbeta3+]
Marking P1.
Priority: P3 → P1
PDT downgrading to P4 since the history window is infrequently visited
Priority: P1 → P4
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP4]
Summary: scrollbar thumb is dragable → scrollbar thumb is dragable in history dialog window
*** Bug 50954 has been marked as a duplicate of this bug. ***
i'll take this
Assignee: slamm → pinkerton
fixed.
Status: NEW → RESOLVED
Closed: 24 years ago
Resolution: --- → FIXED
oops, i guess i didn't really fix this.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
I saw this in FTP listings on Win98 a while back.
really fixed this time.
Status: REOPENED → RESOLVED
Closed: 24 years ago24 years ago
Resolution: --- → FIXED
VERIFIED Fixed with 2000090608 builds
Status: RESOLVED → VERIFIED
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.