Style on table element does not propegate to containing elements

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
18 years ago
18 years ago

People

(Reporter: ken_mori, Assigned: pierre)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)
BuildID:    2000080712

Setting a font style on a dynamically created table does not propagate that 
style to containing elements

Reproducible: Always
Steps to Reproduce:
1.Create a table
2.Set a style class on a table
3.Add some elements to the table

Actual Results:  The font style on the table does not affect text elements 
within a table column					

Expected Results:  Containing elements would inherit the container style except 
when explicitly overridden.
(Reporter)

Comment 1

18 years ago
Created attachment 12965 [details]
Click show button, notice the font style does not impact text
The test case lacks a doctype decalaration and is handled in the quirks mode, in which 
case not inheriting to tables is intentional. Marking invalid.

Please reopen if you see the problem in the standards mode (ie. with the HTML 4 Strict 
doctype declaration).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

18 years ago
So if Netscape 6 is intended to be W3C compliant, why is the default behavior 
based on the Netscape 4 quirks mode?  If the quirks mode is desired, why not 
force an explicit specification of this mode rather than requiring an explicit 
specification for operating in the mode based on W3C standards?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

18 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WONTFIX

Comment 4

18 years ago
see http://www.people.fas.harvard.edu/~dbaron/mozilla/modes for some info on
when and why we use the quirks layout mode. Resolving as wontfix.
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
QA Contact: ian → amar
You need to log in before you can comment on or make changes to this bug.