immediate crash when calling this page

VERIFIED WORKSFORME

Status

()

P3
major
VERIFIED WORKSFORME
18 years ago
18 years ago

People

(Reporter: andreas_plesch, Assigned: clayton)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16-3 i686; en-US; m18) Gecko/20000814
BuildID:    200081412

When browsing to above URL, mozilla crashes and leaves a core.

Reproducible: Always
Steps to Reproduce:
1.go to http://my.harvard.edu
2.
3.

Actual Results:  crash and core dump

Expected Results:  forwarding to
https://www.fas.harvard.edu/cgi-bin/PIN/authen/authen.cgi?__application=FAS_HASCS_portal&original_request=%2Fcgi%2Dbin%2Fportal%2Ecgi
and display

Here are the first lines of the backtrace in gdb:
    (gdb) bt
#0  0x40ef384e in NSGetModule ()
   from /home/andreas/mozilla/package/components/libgklayout.so
#1  0x40ef5194 in NSGetModule ()
   from /home/andreas/mozilla/package/components/libgklayout.so
#2  0x40ef7242 in NSGetModule ()
   from /home/andreas/mozilla/package/components/libgklayout.so
#3  0x40ef3be5 in NSGetModule ()
   from /home/andreas/mozilla/package/components/libgklayout.so
#4  0x40fc491b in NSGetModule ()
   from /home/andreas/mozilla/package/components/libgklayout.so
#5  0x40090015 in nsSupportsArray::EnumerateForwards ()
   from /home/andreas/mozilla/package/./libxpcom.so
#6  0x40fc4c46 in NSGetModule ()
   from /home/andreas/mozilla/package/components/libgklayout.so
#7  0x40db5dfd in NSGetModule ()

They are the reason why I chose layout as component.
(Reporter)

Comment 1

18 years ago
Created attachment 12972 [details]
back trace after core dump

Comment 2

18 years ago
Something is funny there but can't confirm a crash:
w. linux build 2000081509 nothing loads at all - all i see is this in console:

Error loading URL http://my.harvard.edu/

Comment 3

18 years ago
Not crashing on linux 2000-08-15-05 either.

Comment 4

18 years ago
Adding crash keyword.
Keywords: crash
(Reporter)

Comment 5

18 years ago
now with 2000-08-15-15 (Linux) in console:
Adding http://my.harvard.edu to urlbar history
Error loading URL http://my.harvard.edu/
confirm R.K.Aa

PS: on 200081412 I had the NeoClassic and Native.Windows themes and the
multi-themed Aphrodite structure installed but Classic running when crashed.
Maybe irrelevant.
(Right now strange behaviour of comment field: cursor walks outside the top of
the box one line.)

Comment 6

18 years ago
omnipresent cursor is bug 45881.
However: browsing source i find that http://my.harvard.edu will redirect to
https://www.fas.harvard.edu/cgi-bin/PIN/authen/authen.cgi?__application=FAS_HASCS_portal&original_request=%2Fcgi%2Dbin%2Fportal%2Ecgi

Reporter: Do you have PSM installed? If not, that explains the page not loading.

Comment 7

18 years ago
Some more mumbling:

a crash when going to https sites and PSM was not installed was bug 40436
That is marked fixed however, but a newer and similar bug was recently filed:
bug 48837 "crash when clicking on "Add to shopping cart" when PSM not installed"
(happening on linux with build ID 2000081306 and also NT). Maybe that was the
crash that happened in this bug also?
Talkback incidents IDs-WinNT 15756990, Linux 15756978
(Reporter)

Comment 8

18 years ago
No, I do not have the Personal Security Manager installed. I did not realize
that I need PSM to be forwarded to a https:// page although I mentioned the
forwarding originally. I suppose without PSM, the message
Error loading URL http://my.harvard.edu/
is to be expected and not a bug. I could try to reinstall the older build
freshly to see if it crashes without the extra themes but as newer builds appear
not to have this problem anyway I would prefer to leave this just behind as it
is. I there a good keyword for daily (nightly) build specific behaviour ?

Comment 9

18 years ago
in bug 48837 there's a comment about the usual alert-box regarding secure sites
is missing. I assume that is perceived as part of that bug.

As for good daily keywords regarding builds - well.. Personally I browse the
summaries of bugs filed in Bugzilla the past 24 hours, before i download new
builds.

You can also check out http://www.mozillazine.org - they provide a "toolbar"
with "thumbs up/down" icons. A brief comment about builds will display when you
hold mouse over those icons.
(Reporter)

Comment 10

18 years ago
I am not sure if this is the same bug as bug 48837. I get somewhat different
behaviour for the URLs cited there and added a comment which refers to this bug.
So there is a linkage now without speculating about duplication.
Will check the 24h bugs next time.
From what I understand https: is not expected to work, so all these reports may
not be very meaningful.

Comment 11

18 years ago
https works and requires PSM. If you wish to test it, a beta is available at
http://docs.iplanet.com/docs/manuals/psm/psm-mozilla/index.html

Note: If only root has write access to the dir moz is in, fire up the browser as
root, click link, follow instructions to download/install.
When installation has succeeded: quit moz, then start it again as your regular
user. Things should now work and you are ready to file real PSM bugs ;)

Apart from that: This bug has not been tagged duplicate of 44837 - i merely
pointed out a possible connection. The talkback incidents should  be compared to
your attachment to determine if there are similarities.
Since the crash is hard to reproduce it may wind up as WFM - leaving the rest to
the module owner.
(Reporter)

Comment 12

18 years ago
I installed PSM and everything works as expected. I got my wrong impression from
the PSM project home page at mozilla.org. Actually I was speculating myself
about a possible dup and was not rejecting any statement. The PSM should be more
prominently exposed.

Comment 13

18 years ago
Yes... i agree. Currently you find it as the "Crypto" link in Release Notes.
There's also a bug filed about this:
bug 41510 "PSM should be linked from download page"

Comment 14

18 years ago
I am marking this worksforme.  When I tried this without PSM installed on Linux
2000082208, I just get "error loading...", but no crash.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 15

18 years ago
Not crashing on the Linux Sept 14 build. Page loads and renders correctly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.