clicking links gives no reaction whatsoever

RESOLVED INCOMPLETE

Status

()

--
major
RESOLVED INCOMPLETE
10 years ago
8 years ago

People

(Reporter: senatu66, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01], URL)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 GTB5 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 GTB5 (.NET CLR 3.5.30729)

I recently noticed that clicking links on some websites was leading to no reaction whatsoever. At first I thought it were simply broken links, than started to open these sites in Internet Explorer where I found out that the same links were actually working just fine. I guess it must have something to do with a very recent Firefox update.

Reproducible: Always

Steps to Reproduce:
1.open a website with this problem, see sample URL
2.click on any of the affected links, in this case the thumbnails of the veneers
3.nothing happens
Actual Results:  
nothing

Expected Results:  
new tab with larger sample veneer in this case, but I've seen it on other sites with external links as well.

I do have an awful lot of addons, I've not yet tried to reproduce with all addons disabled. By the way, Firefox 3.x crashes a lot more than 2.x and never reports any crash information, but this problem is no crash.
about:buildconfig

Build platform
target
i686-pc-mingw32

Build tools
Compiler 	Version 	Compiler flags
cl 	14.00.50727.762 	-GL -wd4624 -wd4952 -TC -nologo -W3 -Gy -Fd$(PDBFILE)
cl 	14.00.50727.762 	-GR- -GL -wd4624 -wd4952 -TP -nologo -Zc:wchar_t- -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=browser --enable-update-channel=release --enable-optimize --disable-debug --disable-tests --enable-update-packaging --enable-official-branding --enable-jemalloc --with-crashreporter-enable-percent=10
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch

Comment 1

10 years ago
The problem is JavaScript-related, as the thumbnail has an explicit ONCLICK event handler, pointing to a JavaScript function called "transferView".

This may be a bug in Firefox, but it could also very well be an error in the script function.

I confirm this issue also exists in Mac OS X 10.5.6 (nl_NL) / Firefox 3.5b4 (nl_NL).

Comment 2

10 years ago
Lines 27 & 28 of the sample URL source code read:

if (height==0) {cond2=" "};
else {cond2="height="+(height+70)+""};

As far as Firefox is concerned the semi-colon at the end of line 27 is erroneous and needs to be removed.  That IE parses this and works is interesting and raises the question of whether this syntax is valid according to the ECMAscript spec.

Comment 3

9 years ago
I have the problem in 3.5, Windows XP Pro. Several tabs loaded and browser in use for some time. Then the problem seems to start on one page and then move to others as I cursor over links the arrow doesn't change to the hand and pointing finger and when I click the link nothing happens. I can open another session and everything will work OK for awhile and then pages will start to fail also. The first time it happened I had to restart the computer to resolve the issue. Then the problem reappeared after a couple of days. I never close my browser or shut down my computer unless it is required by an update. I haven't experienced a crash in months. I'm running avast and zone alarm an I didn't have the problem in the previous version.
Jim Hurley
(Reporter)

Comment 4

9 years ago
I can confirm Jim Hurley's problem in Firefox 3.5 but this is an intermitting problem, clearly recognisable bij erroneous mouse pointers. I do have the same problem as Jim from time to time but not often and I've not yet been able to describe a way to reproduce it. But the problem from my first message can be reproduced 100% of the time and doesn't effect mouse pointer.

If anyone knows a way to reproduce Jim's bug, please create another bug report.

Comment 5

9 years ago
I uninstalled 3.5 and went back to 3.0.2 and then updated to 3.0.11, which crashed after a couple of days of use. I was offered an update as the fix and so I accepted it and it turned out to be 3.5.1. After it was installed it was locked up imediately so I rebooted my system and it worked fine for a couple of days. Today it locked me out of my links again. I was trying to see if there was a process running that might be causing and I found out that is I went to task manager and then came back to the page I was on it worked, when I went to another page it wouldn't work. It turns out that is you go to another app that is open when you come back the links will be available until you change pages.
This is going to kill me, but it looks like I'm going to have to go back to IE to get some work done. I do some WEB sites for some Conservation Districts and I guarentee them that their site will work in Fire Fox and IE. I don't know how I'm going to do the IE test now.

Comment 6

9 years ago
jim: please file your own bug report.

if firefox is actually not responding (according to windows), then:
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg

!analyze -v -hang
This is a mass search for Firefox General bugs filed against version 3.0 that are UNCO and have not been changed for 200 days.

Reporter, please update to Firefox 3.6.10 or alter. Firefox 3.0 is no longer supported and is no longer receiving updates. After you update, please create a fresh profile, http://support.mozilla.com/kb/managing+profiles, and test to see if your bug still exists. If you still the bug, then please post a comment with the version you tested against, and the problem. If the issue is no longer there, please set the RESOLUTION to  RESOLVED, WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]

Comment 8

8 years ago
This is not a hang, it's merely a syntax error in the JavaScript code. I think this bug can be closed, and the site should be fixed instead.

Here's the offending code snippet:

function transferview(afbeeld,naam,width,height) {
   if (width==0) cond1=" "
   else cond1="width="+(width+20)+"";
   if (height==0) {cond2=" "};            // actual problem is semicolon here
   else {cond2="height="+(height+70)+""}; // the error is reported here instead
   :
}
No reply from reporter, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.