Closed Bug 491229 Opened 10 years ago Closed 10 years ago

DEBUG still defined in liboggz on Windows

Categories

(Core :: Audio/Video, defect)

x86
Windows Vista
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: cpearce, Unassigned)

Details

Attachments

(1 file)

When running a DEBUG build on Windows, I get a debug printf for each frame:

oggz_..._granuleshift: serialno 0692291755 Got frame 4799 (4737 + 62): 159966 units
oggz_..._granuleshift: serialno 0692291755 Got frame 4800 (4737 + 63): 160000 units
oggz_..._granuleshift: serialno 0692291755 Got frame 4810 (4801 + 9): 160333 units
oggz_..._granuleshift: serialno 0692291755 Got frame 4801 (4801 + 0): 160033 units
oggz_..._granuleshift: serialno 0692291755 Got frame 4802 (4801 + 1): 160066 units
oggz_..._granuleshift: serialno 0692291755 Got frame 4803 (4801 + 2): 160100 units

This happens every frame, so slows down playback considerably.

This is because DEBUG is defined while compiling liboggz on Windows. We don't get this on other platforms, Windows only. The problem is here:

http://mxr.mozilla.org/mozilla-central/source/media/liboggz/include/oggz/config_win32.h#138

The "#undef DEBUG" is supposed to be on its one line, but isn't. The script that generates this file is http://mxr.mozilla.org/mozilla-central/source/media/liboggz/update.sh and I believe that is correct. I ran the relevant 3 lines, and that correctly generates config_win32.h.

Kinetik tells me that it looks like the recent liboggz update process somehow left behind this broken config file. Chris Double may be able to shed some light on how this happened, but regardless, it's probably safe to just fix the header.
Attachment #375552 - Flags: superreview?(roc)
Attachment #375552 - Flags: review?(chris.double)
update.sh used to generate this broken file. I fixed update.sh, fixed config.h but neglected to fix config_win32.h, sorry!
BTW, the whole update.sh thing needs fixing in my opinion. It'd be nice if we could call the original libraries 'configure' script during our build process - do you know if this is possible?
Attachment #375552 - Flags: review?(chris.double) → review+
Attachment #375552 - Flags: superreview?(roc) → superreview+
Pushed to m-c: http://hg.mozilla.org/mozilla-central/rev/74d920f1e7fb

I'm sure it must be possible to run configure scripts somehow...
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.