Closed Bug 491251 Opened 12 years ago Closed 8 years ago

Confusing new Feed UI items introduced in Bug 438429

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 599036

People

(Reporter: Thunderbird_Mail_DE, Unassigned)

References

Details

Bug 438429 introduced some new UI / pref items for Feeds.

1) ------------------------------------------------------
View > Feed Message Body As > 
                        Original HTML
                        Simple HTML
                        Plain text
                        -------------
                        Web Page
                        Summary
                        Default Format

Do these HTML options only affect the feed summary? Selecting "Web Page" hides the HTML items from the submenu. Before I understood this, I expected the HTML options would change the Web Page view - not the Summary view?!

2) ------------------------------------------------------
Message > Open Feed Message as >
                        Web Page in new Window
                        Summary in new Window
                        Toggle Web Page and Summary in Message Pane

(Maybe not the original en-US wording above)

- AFAIK in Message menu we only have "action" items doing something, but no prefs. So why do we now insert a pref item? 
- Why is this setting only for new windows? It could be for new tabs, too.
- The wording for "Toggle..." is confusing. It should be clear that (only?) a double click is toggling the view in message pane.
Blocks: 438429
No longer depends on: 438429
(In reply to comment #0)
> Bug 438429 introduced some new UI / pref items for Feeds.
> 
> 1) ------------------------------------------------------
> View > Feed Message Body As > 
>                         Original HTML
>                         Simple HTML
>                         Plain text
>                         -------------
>                         Web Page
>                         Summary
>                         Default Format
> 
> Do these HTML options only affect the feed summary? Selecting "Web Page" hides
> the HTML items from the submenu. Before I understood this, I expected the HTML
> options would change the Web Page view - not the Summary view?!

yes, as you already discovered, these only affect the Summary.  if you have a proposal to make it less confusing/more obvious, state it.
> 
> 2) ------------------------------------------------------
> Message > Open Feed Message as >
>                         Web Page in new Window
>                         Summary in new Window
>                         Toggle Web Page and Summary in Message Pane
> 
> (Maybe not the original en-US wording above)
> 
> - AFAIK in Message menu we only have "action" items doing something, but no
> prefs. So why do we now insert a pref item? 

a feed content is of one of 2 flavors, and options need to be given for which of those flavors the user wants actioned.  this needs to be available easily, and wouldn't belong in Options for example.  what's the problem? 

> - Why is this setting only for new windows? It could be for new tabs, too.

please file an enh for new Open location.

> - The wording for "Toggle..." is confusing. It should be clear that (only?) a
> double click is toggling the view in message pane.

double click and enter will toggle content in message pane if that option is selected.  as for wordsmithing, have at it..
1) ----------
If an other sub menu is allowed, we could have the feed message body options like the following:

View > Feed Message Body As > 
                        Default Format
                        Web Page
                        Summary
                        --------------------
                        In Case of Summary >
                                     Original HTML
                                     Simple HTML
                                     Plain text

2) -------------
> a feed content is of one of 2 flavors, and options need to be given 
> for which of those flavors the user wants actioned.  this needs 
> to be available easily, and wouldn't belong in Options for example.
> what's the problem? 

No real problem - maybe only an unwritten law?
1) imo, another level of menu wouldn't be right.  it's designed that if a summary is showing, the render menu options are shown; if a web page is showing, then they aren't because they don't apply.  seems intuitive so perhaps documentation is the answer, because otherwise there would be menuitem clutter.

2) actually you have a point; ie to maintain consistency there should probably be an option in Options -> Advanced -> Reading & Display like for regular messages.  in rethinking this, the frequency of change of this pref may not be any more than for the similar option for a regular message.  i guess it's up to UI review.
Depends on: 728563
No longer depends on: 728563
#2 has been addressed, see bug 599036 comment 16.  so this is a semi dupe.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599036
You need to log in before you can comment on or make changes to this bug.