Last Comment Bug 49126 - Webclient core dumps on File-->Close
: Webclient core dumps on File-->Close
Status: VERIFIED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Java APIs to WebShell (show other bugs)
: Trunk
: Sun Solaris
: P3 normal with 1 vote (vote)
: ---
Assigned To: Ashu Kulkarni
: geetha.vaidyanaathan
Mentors:
: 49128 50839 (view as bug list)
Depends on: 57725
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-15 16:57 PDT by geetha.vaidyanaathan
Modified: 2012-04-09 22:27 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Full log of crash with threads dump (271.26 KB, text/plain)
2000-08-23 02:10 PDT, Alexei V. Mokeev
no flags Details

Description geetha.vaidyanaathan 2000-08-15 16:57:45 PDT
With M16 build of Mozilla and Aug10 src of webclient,
When I chose close from File menu , webclient core dumps.

-geetha
Comment 1 Peter ``jag'' Annema 2000-08-20 02:35:41 PDT
*** Bug 49128 has been marked as a duplicate of this bug. ***
Comment 2 edburns 2000-08-21 17:24:33 PDT
Reassign to Ashu.
Comment 3 Alexei V. Mokeev 2000-08-23 02:10:12 PDT
Created attachment 13332 [details]
Full log of crash with threads dump
Comment 4 geetha.vaidyanaathan 2000-09-14 17:53:35 PDT
*** Bug 50839 has been marked as a duplicate of this bug. ***
Comment 5 Ashu Kulkarni 2000-11-01 17:20:28 PST
This Bug is fixed with the patch for Bug 57725
Comment 6 Ashu Kulkarni 2000-11-01 17:25:38 PST
Ed,

Pls verify that patch for Bug 57725 fixes this bug. I have shown Geetha that
this bug is fixed by running it on my Sparc - Solaris 8 machine.

_Ashu
Comment 7 edburns 2000-11-02 13:42:27 PST
I'm waiting for my blackwood build to finish.
Comment 8 Ashu Kulkarni 2000-11-06 10:09:02 PST
Fix checked in. Closing Bug.
Comment 9 Alexei V. Mokeev 2000-12-04 23:08:15 PST
This bug is still reproduced on FCS-candidate(from 11/30/2000).
Menu File->Close is absent in this build. But webclient dumps core 
on closing window. End of log looks like:

Got windowClosing
destroying the BrowserControl
ImplObjectNative.delete()
ImplObjectNative.delete()
ImplObjectNative.delete()
ImplObjectNative.delete()
Segmentation Fault - core dumped
<avm@indra(pts/9).342> 

Think this bug should be reopened.
Comment 10 Ashu Kulkarni 2000-12-05 10:23:32 PST
The Fix for this Bug is in the RTM Branch. However sicne we are using the PR3 
build for the FCS candidate, this fix will not be in the FCS bundle. There is 
no need to reopen this Bug.
Comment 11 Vladimir Strigun 2001-10-15 10:50:24 PDT
Verified with: mozilla branch Netscape61_RELEASE and blackwood branch 
JAVADEV_6_1_20010831 under Sparc Solaris 2.8 (Mozilla/5.0 (X11; U; SunOS sun4u; 
en-US; rv:0.9.2) Gecko/20011011). Webclient doesn't core dump and closed 
correctly.
Comment 12 Alexei V. Mokeev 2001-10-16 01:45:50 PDT
VERIFIED

Note You need to log in before you can comment on or make changes to this bug.