[Mac] Different ways to quit Firefox should behave equivalent

RESOLVED DUPLICATE of bug 491122

Status

()

RESOLVED DUPLICATE of bug 491122
9 years ago
9 years ago

People

(Reporter: znerd, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; nl; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

There is a difference between the use of the following ways to quit Firefox in Mac OS X 10.5:
1. use the keyboard shortcut: Cmd-Q
2. use the menu item File -> Quit
3. choose Quit on the Dock icon

Reproducible: Always

Steps to Reproduce:
1. Start Firefox 3.5b4 on Mac OS X 10.5.6
2. Edit one of the regular toolbars, e.g. add the "Copy" action to the navigation toolbar
3. Press Cmd-Q to quit Firefox
4. Start Firefox again (notice the toolbar change is still effective)
5. Edit the toolbar again, e.g. remove the "Copy" action from the navigation toolbar
6. Right-click or Shift-left-click on the Firefox icon in the Dock and select "Quit"
7. Restart Firefox again
Actual Results:  
The change to the toolbar is lost

Expected Results:  
The change to the toolbar is effective

See bug 491122.

I tested on Mac OS X 10.5.6 (nl_NL), with Firefox 3.5b4 (nl_NL).

Updated

9 years ago
Component: General → Toolbars and Toolbar Customization
Product: Firefox → Toolkit
QA Contact: general → toolbars
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491122
You need to log in before you can comment on or make changes to this bug.