watched users are not searched/matched in the same way as CC

RESOLVED DUPLICATE of bug 203309

Status

()

Bugzilla
User Accounts
--
minor
RESOLVED DUPLICATE of bug 203309
9 years ago
9 years ago

People

(Reporter: Alexandra Kossovsky, Unassigned)

Tracking

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.7) Gecko/2009032813 Iceweasel/3.0.6 (Debian-3.0.6-1)
Build Identifier: 3.0.4.1-2+lenny1.1 (from Debian)

When I add some users to my watch list, I should provide the exact name of their bugzilla account. At the same time, if I add a user to CC list of the bug, or when I assign a bug, I may use a keyword to be used with current 'usermatchmode' parameter.  However, 'usermatchmode' parameter does not affect data in watch list.


Reproducible: Always

Steps to Reproduce:
1. set usermatchmode='search', confirmuniqueusermatch='on'.
2. create a user 'xxx@some.domain.com'.
2. In a bug, assign it to xxx and add xxx to CC list -- you'll be asked for confirmation if xxx is really 'xxx@some.domain.com'.
3. try to add xxx to you list of watched users.
Actual Results:  
Error: "The name xxx is not a valid username. Either you misspelled it, or the person has not registered for a Bugzilla account. "

Expected Results:  
Ask for confirmation that xxx is 'xxx@some.domain.com' and add him to my watch list.

Possibly duplicate of bug 487985.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 203309
You need to log in before you can comment on or make changes to this bug.