give Minefield, Shiretoko, and release builds of Firefox unique CFBundleIdentifier values

RESOLVED DUPLICATE of bug 553073

Status

()

Firefox
Shell Integration
RESOLVED DUPLICATE of bug 553073
9 years ago
8 years ago

People

(Reporter: myk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Minefield, Shiretoko, and release builds of Firefox all identify themselves with CFBundleIdentifier org.mozilla.firefox in Info.plist, but Mac OS uses CFBundleIdentifier to uniquely identify applications, so it can't distinguish between them.

Which means that if you have two or more of those applications installed, you can't select which one will be your default web browser.  Or rather, you can select one, but Mac OS X ignores that selection and picks the same one every time no matter what you selected (in my case the OS picks Minefield).

I've tried to set my default web browser via:

* Firefox > Preferences > Advanced > General > System Defaults > Always check
  to see if Shiretoko is the default application on startup > Check Now;

* Safari > Preferences > Main > Default web browser;

* the RCDefaultApp preference pane 
  <http://www.rubicode.com/Software/RCDefaultApp/>.

They all exhibit the same problem, so this is clearly a limitation of Mac OS's LaunchServices to distinguish between these applications when launching the preferred application.  LaunchServices should use a combination of CFBundleIdentifier and path to distinguish these applications, so you can even install two release builds of Firefox to different locations (f.e. so you can have older versions installed for testing purposes) and specify which one you want to be your default browser.

Nevertheless, until that happens (if ever), the obvious workaround on the Firefox side of things is to give the development versions of the application unique CFBundleIdentifiers, keeping org.mozilla.firefox for release builds of Firefox but setting Shiretoko's to org.mozilla.shiretoko and Minefield's to org.mozilla.minefield.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 553073
You need to log in before you can comment on or make changes to this bug.