If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need code profiler for WinCE

RESOLVED DUPLICATE of bug 493427

Status

()

Core
Rewriting and Analysis
RESOLVED DUPLICATE of bug 493427
9 years ago
8 years ago

People

(Reporter: cjones, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

There is a pathetic dearth of these tools for WinCE.  We will probably have to take this on ourselves.

We have several approaches
 - "stopwatch"-style C++ instrumentation Taras has been doing (heavyweight)
 - assembly instrumentation to count basic block executions (medium weight)
 - biting the bullet and writing a proper WinCE profiling kernel module (lightweight)
>  - biting the bullet and writing a proper WinCE profiling kernel module
> (lightweight)

Oops, by "profiling" I meant "sampling."
Similar work is happening in bug 491373
(In reply to comment #2)
> Similar work is happening in bug 491373

Sorry, you just sent me into an infinite loop.
(In reply to comment #3)
> (In reply to comment #2)
> > Similar work is happening in bug 491373
> 
> Sorry, you just sent me into an infinite loop.

Ugh - bug 493427
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 493427
You need to log in before you can comment on or make changes to this bug.