Closed Bug 491385 Opened 13 years ago Closed 13 years ago

WAV file doesn't play

Categories

(Firefox :: General, defect)

x86
macOS
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 475110

People

(Reporter: msridhar, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.10) Gecko/2009042315 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4

When I visit the given URL, I see a spinner, but I never hear the WAV file play.  In Firefox 3.0.10, the WAV plays immediately using the QuickTime plugin.  I believe this issue makes using the web-based interface to our voicemail system at work impossible to use in Firefox 3.5.  

I tested with a fresh profile with Firefox 3.5 Beta 4.

Reproducible: Always

Steps to Reproduce:
1. Visit http://www.nch.com.au/acm/8kulaw.wav
2.
3.
Actual Results:  
See a spinner but hear nothing.

Expected Results:  
Should have played the file.
Marking as possibly blocking since this seems to be a pretty bad regression from Firefox 3.0.
Flags: blocking-firefox3.5?
Firefox does not support non PCM encoded Wave files, which is the case from the file liked above:

file 8kulaw.wav 
8kulaw.wav: RIFF (little-endian) data, WAVE audio, ITU G.711 mu-law, mono 8000 Hz

duplicate of bug 475110.

There is another issue I'm going to file: the UI should notify in some way that this file is invalid instead of having the spinner keep spinning.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 475110
Filed bug 491410 for assertion failure on a debug build / UI notification.
Flags: blocking-firefox3.5?
You need to log in before you can comment on or make changes to this bug.