Remove GCAllocObject-based inheritance of MMgc classes

VERIFIED DUPLICATE of bug 488738

Status

VERIFIED DUPLICATE of bug 488738
10 years ago
9 years ago

People

(Reporter: rishah, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
Following classes inherit GCAllocObject -

1. FixedMalloc
2. FixedAlloc
3. GCAlloc
4. GCLargeAlloc
5. GCHeap
6. HeapBlock
7. Region

Comment 1

10 years ago
SpinLock* classes do too

Updated

10 years ago
Assignee: rishah → nobody

Updated

10 years ago
Depends on: 503134

Updated

9 years ago
Blocks: 489345

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 488738

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.