Closed Bug 491392 Opened 11 years ago Closed 10 years ago

browser.urlbar.matchBehavior with value 3 doesn't ignore www. in URLs

Categories

(Firefox :: Address Bar, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 461483

People

(Reporter: kebrus, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090504 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090504 Minefield/3.6a1pre

browser.urlbar.matchBehavior with a value of 3 searches for matches only in the begging of urls, titles, etc but while this might be useful for titles, is almost useless with urls because it doesn't ignore "www." when needed... 

since most pages do start with the www. prefix it takes away almost all of the functionality of this preference

Reproducible: Always

Steps to Reproduce:
1. browser.urlbar.matchBehavior = 3 (matching only the beginning)
2. browser.urlbar.default.behavior = 16 (matching only URLs)
3. type "google" in the location bar (you need to have it in your history or bookmarks)
Actual Results:  
autocomplete function doesn't suggests "www.google.com" in the dropbox list of suggestions

Expected Results:  
autocomplete should ignore www. prefix in URLs when needed and show the correct suggestions, this means ignoring "www." prefix only in pages that actually start with it

while it doesn't ignore "www." it does ignore "http://" in URLs
Version: unspecified → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 461483
You need to log in before you can comment on or make changes to this bug.