Various local usages of "id" need to be renamed to avoid possible conflict.
Created attachment 375719 [details] [diff] [review] Patch Corrects usages in AvmCore.cpp: "id" -> "ident"
Attachment #375719 - Flags: review?(edwsmith)
Comment on attachment 375719 [details] [diff] [review] Patch in the first diff hunk, renaming 'id' to 'ident' makes sense. the remaining 'id' variables stand for 'integer double', ie a double that was converted to an int. calling them ident is misleading. intval or anything else sensible in context, would be fine.
Attachment #375719 - Flags: review?(edwsmith) → review-
good catch. ok to push if I change the second set to "intval" or some such?
Created attachment 375834 [details] [diff] [review] Patch updated patch with better renames.
pushed to redux as changeset: 1840:2ec02b439233
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Resolved fixed engineering / work item that has been pushed. Setting status to verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.