Closed Bug 491410 Opened 13 years ago Closed 12 years ago

Unsupported .wav formats cause "ABORT: Invalid state transition:" assertion failure.

Categories

(Core :: Audio/Video, defect)

All
Linux
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 481057

People

(Reporter: sylvain.pasche, Unassigned)

References

Details

Attachments

(1 file)

I noticed this when trying to open a .wav file from bug 491385 (dup of 475110).

The wave file in question is compressed PCM:

file 8kulaw.wav 
8kulaw.wav: RIFF (little-endian) data, WAVE audio, ITU G.711 mu-law, mono 8000
Hz

Then you get:
WARNING: WAVE is not uncompressed PCM, compressed encodings are not supported: file mozilla/content/media/video/src/nsWaveDecoder.cpp, line 1019
###!!! ABORT: Invalid state transition: 'IsValidStateTransition(mState, aState)', file mozilla/content/media/video/src/nsWaveDecoder.cpp, line 819

In a non-debug build, the spinner keeps spinning. Ideally there should be some kind of UI notification when the .wav file is broken instead.
We need to fire decode errors for this case, but some of the code isn't implemented yet.  There's a bug for doing so: bug 481057.
Depends on: 481057
Once we fire these events, the UI should show the "broken file" icon, since it is already wired up to do this for the other types of media errors that can happen.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 481057
You need to log in before you can comment on or make changes to this bug.