Keyboard shortcut for Simple HTML / Original HTML toggle (View | Message Body As)

RESOLVED WONTFIX

Status

Thunderbird
Message Reader UI
--
enhancement
RESOLVED WONTFIX
9 years ago
8 years ago

People

(Reporter: BenB, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Phil requested that it's possible to toggle between Original HTML and plaintext per a keyboard shortcut.
I think we should toggle to Simple HTML instead, because it's about as secure as plaintext (heavily sanitized / scrutinized) and looks much better and preserves more information, like tables etc..

Comment 1

9 years ago
I'd like a button in the preview pane header--next to hide details and other actions.
'Toggle View' with text message underneath stating what is on. Html, Simple Html or Simple Text
Current keyboard shortcuts are alt-vb. And I think there are some keyboard assignment extensions out there.

Comment 2

9 years ago
Created attachment 377039 [details] [diff] [review]
adds toggle button to header for changing message body view

toggles views of message to html, restricted html and plain text.
(Reporter)

Comment 3

9 years ago
I don't think this warrants to have a button for this (in default TB - extension would be fine), but Bryan would decide that.
Good to see this getting some attention!  Please attach a screenshot, request ui-review from clarkbw@gnome.org, and he can make that call.

Comment 5

9 years ago
Created attachment 377302 [details]
composite picture of toggle views

This shows the button in all three body views and sample email in preview pane.
Attachment #377302 - Flags: ui-review?(clarkbw)
Comment on attachment 377302 [details]
composite picture of toggle views

(In reply to comment #3)
> I don't think this warrants to have a button for this (in default TB -
> extension would be fine), but Bryan would decide that.

Ben and I are in complete agreement as always.  This makes a lot more sense as an extension than in the default TB.
Attachment #377302 - Flags: ui-review?(clarkbw) → ui-review-
Duplicate of this bug: 362971
Severity: minor → enhancement
(In reply to comment #2)
> adds toggle button to header for changing message body view
> toggles views of message to html, restricted html and plain text.

Does this new toggle view changes Tb wide View/Message Body As setting? Or this new toggle view changes View/Message Body As mode of currently displayed mail only? If latter, and button is added, enhancement request of Bug 495548 will be fulfilled.

Can this bug's enhancement easily be ported to enhancement of ad-hoc/per-mail "View/Display Attachments Inline"?

No plan to add button? I think button for this enhancement is far useful than "Not Junk" button in message header pane of Junk mail.

Comment 9

9 years ago
->WONTFIX then. I strongly doubt enough users do this regularly to warrant more access points than we have.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX

Comment 10

9 years ago
WONTFIX? Outlook has this option in it's top bar by default... I use it very often; very handy when replying to mails sent via Webmail interfaces. Many users I know that use TB find it very confusing not being able to toggle this option. They often complain that their 'font drop down' is broken.
I hope TB will implement this option.
You need to log in before you can comment on or make changes to this bug.