very wide popups can have parts ofscreen

RESOLVED FIXED in Future

Status

()

P3
normal
RESOLVED FIXED
18 years ago
17 years ago

People

(Reporter: mscott, Assigned: mikepinkerton)

Tracking

({polish})

Trunk
Future
x86
Windows NT
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Hey Mike,
So I have a popup in the message pane that shows you all the headers in the
message. So it's a large popup. You can see it by clicking on the header name in
the message pane i.e. "To:" or "From:"

The popup is declared as follows:
<popup id="allHeadersPopup"  oncreate="return
fillAllHeadersPopup(document.popupNode);" popupanchor="bottomleft">
	<box id="allHeadersPopupContainer">
	</box>
</popup>

I'm pretty sure this used to work. But recently when I click on the popup,
instead of coming up with the upper leftmost corner of the popup starting where
the mouse is, it's coming up with that being the lowest right corner. This
results in most of the popup coming up on the left side of the screen and most
of it is actually off screen.

Do you see anything I'm doing wrong in my declaration of the popup? The box gets
filled in by the oncreate handler.

I suspect the problem has to do with the size of the popup. I have another popup
that's invoked when you click on an email address in the message pane. This is a
much smaller popup and it's anchored correctly.
(Reporter)

Updated

18 years ago
Keywords: polish
(Assignee)

Comment 1

18 years ago
the problem is the size of the popup. when a popup can't fit where it is told to 
go, we pull and push and move it to fit on the screen.

the fact that we don't shrink it horizontally to fit on the screen is probably a 
bug, something we didn't have to deal with in xpmenus (where all this code comes 
from). 

this probably isn't priority for ns6, given that this won't be a very well known 
feature. i'm inclined to future it, what do you think?
Status: NEW → ASSIGNED
Summary: popups aren't getting anchored correctly... → very wide popups can have parts ofscreen
(Reporter)

Comment 2

18 years ago
Mike, can you think of any kind of work around I could try that wouldn't involve
you having to fix the bug for RTM?
(Assignee)

Comment 3

18 years ago
mmmm, maybe don't make the popup so wide? ;) honest, that's about it.
(Assignee)

Comment 4

18 years ago
futuring
Target Milestone: --- → Future
(Assignee)

Updated

18 years ago
Target Milestone: Future → mozilla1.0
(Assignee)

Updated

18 years ago
Target Milestone: mozilla1.0 → mozilla0.9

Comment 5

18 years ago
*** Bug 63869 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

18 years ago
Target Milestone: mozilla0.9 → Future

Comment 6

18 years ago
*** Bug 74214 has been marked as a duplicate of this bug. ***

Comment 7

18 years ago
allHeadersPopup doesn't work on recent builds.

Nothing happens when I click "Subject:" or "From:" header.
You have to click in the "Subject", "From" or another word in the body
of the email.
A tooltip appears and show all the headers of the email.
I have two screenshot screenshots, showing the behavior.
Shouls I send them? It weight 338kb.

This happens in Windows 98 and Linux (Redhat 7.0) with Mozilla 0.8.1
and previous builds, like the Mxx series.
(Reporter)

Comment 9

18 years ago
I removed the all headers "feature" which was just something I put in as a hack.
The popup was coming up way to big for it to be useful AND it wasn't
discoverable.  I'm planning on implementing a new view all header mode for the
new message display anyway.

Updated

18 years ago
Depends on: 73413

Comment 10

17 years ago
"allHeadersPopup" has been replaced with "expandedHeaderView".
This bug can be marked as FIXED.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.