Status bar should display port number when it's not 80

RESOLVED WONTFIX

Status

()

Core
Networking
P3
enhancement
RESOLVED WONTFIX
18 years ago
2 years ago

People

(Reporter: Dan Nunn, Unassigned)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20000814
BuildID:    2000081415

Visiting a URL with a port number other than 80 will not display the port number
in the Status Bar with the "Sending request to [url]", "Contacting [url" messages.

Reproducible: Always
Steps to Reproduce:
1. Go to an HTTP URL with a port other than 80.
2. Observe the status bar.

Actual Results:  Status bar (for the URL listed) states "Sending request to
chatsrv.warnerbros.com"

Expected Results:  Status bar (for the URL listed) in 4.x states "Connect: Host
chatsrv.warnerbros.com:4080 contacted, waiting for reply...", an albeit
different message, but with the appropriate port.

Comment 1

18 years ago
Well it's not saying sending request to [url], it's saying sending request to
[host].
If it was saying it was sending a request to URL it would have the whole thing
(including protocol (http:) and path) displayed.

Netscape just chose to also supply the port number when requesting a port other
than 80.

This isn't a bug in Mozilla, it just does things differently.

I think this is more of a request for an enhancement rather than a bug.

So I'm going to confirm the bug but change its severity to enhancement (and
slighly modify the summary so it looks like an enhancement request).

If you'd like this to be implemented in Mozilla then please vote for this.
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: PC → All
Summary: Status bar does not display port number when it's not 80 → Status bar should display port number when it's not 80

Comment 2

18 years ago
over to Networking.
Assignee: asa → gagan
Component: Browser-General → Networking
QA Contact: doronr → tever
Summary: Status bar should display port number when it's not 80 → [RFE] Status bar should display port number when it's not 80

Updated

18 years ago
Target Milestone: --- → Future

Comment 3

17 years ago
mass move, v2.
qa to me.
QA Contact: tever → benc

Comment 4

17 years ago
+mozilla1.0 - we need to fix several other parts of status, might as well do it
right.
Keywords: mozilla1.0

Updated

16 years ago
Summary: [RFE] Status bar should display port number when it's not 80 → Status bar should display port number when it's not 80
Assignee: gagan → nobody
QA Contact: benc → networking
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.