Closed Bug 491799 Opened 13 years ago Closed 13 years ago

mozicon128.png not copied during Thunderbird build

Categories

(Thunderbird :: Build Config, defect)

All
Linux
defect
Not set
minor

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b3

People

(Reporter: david.ward, Assigned: standard8)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.10) Gecko/2009042523 Ubuntu/9.04 (jaunty) Firefox/3.0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b5pre) Gecko/20090504 Thunderbird/3.0b3pre

I am building Thunderbird from source using the --enable-official-branding option in .mozconfig (for my own personal use only of course).  The icon file mozicon128.png (located in the source tree at other-licenses/branding/thunderbird) is not copied over to mozilla/dist/branding or to mozilla/dist/bin/icons during the build process.  As a result, this PNG icon is not a part of the tarball package produced by the build.  However, when building Sunbird from the very same source tree with the same build options, the Sunbird version of mozicon128.png is successfully copied to the above directories and into the tarball package.  This has been happening for months with any combination of build options I have used.  (I can provide specific build configuration options if desired, but I think you should be able to reproduce this bug without that).

Reproducible: Always
Taking, this seemed to get included once in bug 262265 and then backed out almost straight away. We're just missing the necessary makefile lines to make coping to the tarball happen.
Assignee: nobody → bugzilla
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch The fixSplinter Review
Attachment #376213 - Flags: review?(mkmelin+mozilla)
Target Milestone: --- → Thunderbird 3.0b3
Attachment #376213 - Flags: review?(mkmelin+mozilla) → review+
Fix works for me.
Checked in: http://hg.mozilla.org/comm-central/rev/1abc1fccf61e
Status: NEW → RESOLVED
Closed: 13 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Additional solaris bustage fix pushed: http://hg.mozilla.org/comm-central/rev/56366a5e74bf (change -e to -f).
You need to log in before you can comment on or make changes to this bug.