Can't log-in with an Open ID if your username contains a capital letter

RESOLVED FIXED

Status

Cloud Services
General
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Rockridge, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b5pre) Gecko/20090506 Shiretoko/3.5b5pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; ja; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4 ID:20090423204732

The latest Weave snapshot supports Open IDs. It looks like a username is used as part of an Open ID, e.g. "https://services.mozilla.com/openid/foo."

The problem is Weave seems to send an Open ID all as small letters. If your username contains at least one capital letter, the sent ID doesn't match your actual ID. There's no surprise the log-in fails.

Reproducible: Always

Steps to Reproduce:
1. Install the latest Weave snapshot (0.3.2).
2. Visit the URL.
3. Click "Sign In Using Weave."
Actual Results:  
Confirmation of the Open ID failed.

Expected Results:  
The log-in is successful.

Updated

9 years ago
Target Milestone: -- → 1.0

Updated

9 years ago
Component: Weave → Needs Triage
Product: Mozilla Labs → Weave
Target Milestone: 1.0 → ---
QA Contact: weave → needstriage
(Reporter)

Comment 1

9 years ago
The bug I reported seems to be fixed in Weave 0.3.3.
I can log-in successfully now.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

8 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
You need to log in before you can comment on or make changes to this bug.