Problem displaying Flickr pages on some Windows XP systems

RESOLVED WORKSFORME

Status

()

Firefox
General
--
major
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: Robert Jurjevic, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-12-01], URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

On some Windows systems (XP and Vista, 32- and 64-bit) it has been observed that the following web page:
http://www.jurjevic.org.uk/photography/flickr/fliter/1.htm

does not display properly (not a single thumbnail is displayed) when viewing with Firefox 3.0.8, 3.0.9, 3.0.10 or 3.1 Beta 3 (listed only version which were tested). The systems which suffer from this problem also show problems displaying other Flickr pages, say this one (most of the images are not displayed):
http://www.flickr.com/photos/13816725@N04/

It is likely a bug in Firefox, as say IE 8 does not show the problem. I failed to find out what is the cause (disabling all of my add-ons did not help). Firefox 2.0.0.20 does not show the problem. There are Windows XP systems where this problem does not show (failed to figure out in what way these systems are different from the one where I am having the problem).

Additional info:
http://wp.dembowski.net/2008/07/19/flickr-firefox-3-problem/


Reproducible: Always

Steps to Reproduce:
1. try to load or refresh the http://www.jurjevic.org.uk/photography/flickr/fliter/1.htm in Firefox 3.0.8, 3.0.9, 3.0.10 or 3.1 Beta 3 and if no thumbnail appears you have reproduced the problem

Actual Results:  
no or most images are not displayed on the web pages

Expected Results:  
all of the images are expected top be displayed on the web pages

I marked Severity to be "Major: A major feature is broken" as http://www.flickr.com/ is rather popular and important service on the Internet, and some people (including me) may consider stop using Firefox because of that (switching to some other web browser, say IE 8 does not show the problem)

Comment 1

9 years ago
This surely much be a duplicate of something, but I can't find the bug. I think I have had this problem on Flickr since i upgraded to Firefox 3. I haven't searched for the problem here before today, when a friend of mine asked if I had the same problem. And then I find a bug created today... So it must be a well known / "normal" problem?
I have an ATI card, my friend a Nvidia. So it doesn't seem to be dependent on videocard.
Looking forward to see which bug this is a duplicate of so I can vote for it and monitor progress :-)

Comment 2

9 years ago
Bug #474886 ?
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.11pre) Gecko/2009050506 GranParadiso/3.0.11pre

I see them all.
Version: unspecified → 3.0 Branch
(Reporter)

Comment 4

9 years ago
I do apologize if I reported a bug which has already been reported, I was aware that there were reports about problems with Flickr and Firefox 3, nevertheless the problem occurs only on some Windows systems and as far as I know nobody has found the reason why, i.e. what is different on those problematic Windows systems, the reason I reiterated the bug is that I found a simple web page which is not displaying properly (the page is basically a set of image links to Flickr pages where the images are thumbnails residing on Flickr), the original bug reports were referring different Flickr web pages and were not so clear about what is Firefox not doing and it ought to (some Flickr pages are displayed partially, etc.), and I thought that this simple web page which is failing to display properly might help Firefox programmers to find the problem.

I have problems on one of the three Windows systems I am using (but have failed to figure out in what way the problematic Windows system is different), it is possible that the bug is quite rare, and perhaps that is why it was given so little attention, but as on my problematic Windows OS Firefox 2.0.0.20 (as well as IE 8) displays the page properly, I assume that the problem is in Firefox 3.

I suspect it could be related to internal Firefox cashing or a way how Firefox 3 display graphics (say is it sometimes using open GL, etc.), but it is only a guess.
Version: 3.0 Branch → unspecified

Comment 5

9 years ago
Robert, I'm not attacking you if you got that impression. As I said, I had trouble finding the right bug too in the system.
(Reporter)

Comment 6

9 years ago
sure, no problem...
(Reporter)

Comment 7

8 years ago
Unfortunately I still see the problem with Firefox 3.5.1 ...

http://www.jurjevic.org.uk/photography/flickr/fliter/1.htm

does not display correctly on of my Windows XP (Professional) systems (10 thumbnails should be displayed in each row).
(Reporter)

Comment 8

8 years ago
On some Windows systems (XP and Vista, 32- and 64-bit) it has been observed that 

http://www.jurjevic.org.uk/photography/flickr/fliter/1.htm

does not display properly (no or some thumbnails are displayed) when viewing with Firefox 3.0.8, 3.0.9, 3.0.10, 3.1 Beta 3 or 3.5.1. The systems which suffer from this problem also show problems displaying other Flickr pages. It is likely a bug in Firefox, as say IE 8 does not show the problem, but I failed to find out what is the cause (disabling all of my add-ons did not help). Firefox 2.0.0.20 does not show the problem.

http://wp.dembowski.net/2008/07/19/flickr-firefox-3-problem/

Solution: when viewing the page in Firefox 3.5.1 I went to menu Tools/ Page Info and in the dialogue I clicked on Details button, then selected Media tab, then I kept clicking back and forth on items in the list (those items were references to the thumbnails), then I closed the dialogue and refreshed the page, all of the thumbnails showed up, looks like other Flickr pages also display correctly, you can even re-open the Firefox and still get all of the thumbnails displayed.

Well, I hope that this method may work for you as well. :)

Here are some sample test pages (which should show correctly if you have fixed the problem):

http://www.jurjevic.org.uk/photography/flickr/fliter/examples/1.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/2.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/3.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/4.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/5.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/6.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/7.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/8.htm
http://www.jurjevic.org.uk/photography/flickr/fliter/examples/9.htm

Thanks.
Reporter, please retest with Firefox 3.6.12 or later in a fresh profile (http://support.mozilla.com/kb/Managing+profiles). Also update your plugins (flash, adobe reader, java, quicktime, silverlight, etc.) Go to the developer's website and download the latest version from there. If you no longer see this issue, please close this bug as RESOLVED, WORKSFORME. If you do see the bug, please post a comment.
Whiteboard: [CLOSEME 2010-12-01]
(Reporter)

Comment 10

7 years ago
The described method of fixture worked for me. I use 3.6 and see no problem. Therefore I will close the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Updated

7 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.