browser.display.screen_resolution is ignored by content area

VERIFIED INVALID

Status

()

Core
CSS Parsing and Computation
P3
major
VERIFIED INVALID
18 years ago
17 years ago

People

(Reporter: John Ellson, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: (py8ieh: high res pixels))

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
$HOME/.mozilla/default/prefs.js
	user_pref("browser.display.screen_resolution", 400);
is ignored by the main browser window.


(How about an option to simply force a single font size???)

Comment 1

18 years ago
Do you really have a 400 dpi screen?  WOW!

BTW, in a debug build, you get a startup message about what mozilla thinks your
screen resolution is.  Compare with xdpyinfo.

Comment 2

18 years ago
*** Bug 49190 has been marked as a duplicate of this bug. ***

Comment 3

18 years ago
Confirming on Linux 2000-08-16-05.  The problem is that the chrome typography is
scaling with the screen resolution setting, while the rendered content area is
not.  To reproduce:

1) Set browser.display.screen_resolution to 1000 dpi
2) Start Mozilla

The problem is nicely shown in the attached screen shot, sent to me by the
original reporter.  Not sure who this belongs to, sending to Style.
Assignee: asa → pierre
Status: UNCONFIRMED → NEW
Component: Browser-General → Style System
Ever confirmed: true
QA Contact: doronr → chrisd
Summary: browser.display.screen_resolution is ignored by main window → browser.display.screen_resolution is ignored by content area
(Assignee)

Comment 4

18 years ago
Closed as invalid: the content area does take the screen resolution into account. 
See http://www.w3.org/Style/CSS/Test/current/sec61.htm for instance: all the 
values specified in absolute units such as inches or centimeters are affected by 
the screen resolution. You can't see it when browsing common web sites because 
they use pixels.

See bug 17926 for more information about screen resolution within the chrome.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

18 years ago
If the content area took screen resolution into account, then its size
would change when the resolution is modified.  It doesn't.

The basic problem is that currently it is impossible to read any page
that uses <font size=1> or <font size=2> on a high resolution monitor
(reallistically about 96/inch instead of the default 72)

Four possible fixes:
	1. Support the adustable screen resolution settings.
	2. Add option to enforce a minumum font size
	3. Support decent antialiased fonts (likely an X11 problem)
	4. Fix the stupid HTML feature that allows authors to 
	specify absolute font sizes.

Mozilla already has an option to set resolution.  It should just use it!
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Comment 6

18 years ago
The content takes the screen resolution into account (of course, the sizes have 
to be specified in inches or points - not in pixels or ems). See the attached 
testcase. Or is there a problem on unix only? That would be surprising.

#1 is invalid - see attached testcase
#2 is dup of bug 30910, also related to bug 46286

Closed as invalid again.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → INVALID
(Assignee)

Comment 7

18 years ago
Created attachment 13296 [details]
testcase
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
The four possible fixes are currently either done or covered by other bugs.
Status: RESOLVED → VERIFIED
Whiteboard: (py8ieh: high res pixels)
You need to log in before you can comment on or make changes to this bug.