Improve Error messaging for "Don't Share"

RESOLVED WORKSFORME

Status

()

Core
Geolocation
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: marcia, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Apologies if this is a dupe, but I could not find a bug which specifically addresses this: When I select "Don't Share" I get "Error 1"

Also, for the sites that I decide not to share, where can that list be managed from? I am thinking of the UI we have for offline where there is already an explicit list of exceptions - is the same planned for geo? Or maybe does not make as much sense?

Comment 1

9 years ago
it is fine and expected to see "error 1" if you don't share.  This is by design:

http://www.w3.org/TR/geolocation-API/#position_error_interface


There isn't any UI to show you every site you have visited and changed geolocation permissions on.  However, you can go to Page Info an a specific site to see what permissions you may have granted it.

Comment 2

9 years ago
wfm?
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.