Thunderbird (Shredder) hangs when resuming from sleep, requires force quit

RESOLVED DUPLICATE of bug 494849

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 494849
9 years ago
9 years ago

People

(Reporter: mjh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090427 Shiretoko/3.5b5pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b5pre) Gecko/20090507 Shredder/3.0b3pre

I do not believe this is a duplicate of Bug 473483.

When resuming from sleep, Thunderbird will hang and is unable to brought to the front. This is on an x86 Mac OS 10.5.6 MacBook Pro.

Although this may be unrelated, I recently changed my 

Reproducible: Always

Steps to Reproduce:
1. Launch Thunderbird
2. Connect and check mail
3. Close lid of laptop or sleep
4. Open lid
5. Try to bring Thunderbird to the front
Actual Results:  
Thunderbird is hung, non responsive

Expected Results:  
Thunderbird will open and come to the front

Crash log and sampling of process attached.
(Reporter)

Comment 1

9 years ago
Created attachment 376357 [details]
Crash log and process sample
(Reporter)

Comment 2

9 years ago
Sorry, I didn't complete a sentence earlier. 

A couple days ago I updated my digital signing certificate when Tbird notified me the key was wrong. Upon checking, the key was in fact incorrect. However, it appears the configuration changed without my interaction as I have not changed my keys recently and Tbird 2.x worked fine.

Additionally, this was after the first time this resume from sleep crash happened. Since I corrected the keys, they have remained correct.

Comment 3

9 years ago
so, there's some form of lock/monitor contention, you're going to need to find someone who has a build w/ symbols.

oddly enough, i just got a nice macbookpro and could probably end up looking into this. but atm i'm traveling for business, so....
Let's track this issue in bug 494849 - it looks it's the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 494849
You need to log in before you can comment on or make changes to this bug.