If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Bookmark Menu extends over StatusBar and TaskBar

VERIFIED WONTFIX

Status

()

Firefox
Bookmarks & History
VERIFIED WONTFIX
9 years ago
8 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

When opening the Bookmarks Menu from the Menu Bar the Bookmark list will extend over the StatusBar and the Taskbar in Vista HP. 

This makes it impossible to see the URL in the StatusBar for those links in folders/sub-folders that do not display a 'tooltip' for the Bookmark, you can only examine the URL in the StatusBar in that case, but with the Menu extending over it, you can't. 

Not sure when this may have regressed, if it did, as I seldom use the Bookmarks Menu List due to the usefulness of the 'Awesome Bar' 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090508 Minefield/3.6a1pre Firefox/3.0.7 ID:20090508045101Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090508 Minefield/3.6a1pre Firefox/3.0.7 ID:20090508045101Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090508 Minefield/3.6a1pre Firefox/3.0.7 ID:20090508045101
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090508 Minefield/3.6a1pre ID:20090508045101

same on XP
Also on Linux.
OS: Windows Vista → All
changing summary due to comment 2.
Summary: Bookmark Menu extends over StatusBar and TaskBar on Windows Vista → Bookmark Menu extends over StatusBar and TaskBar
This is normal behavior for menus for all applications under both Windows and Linux.

It is kind of unfortunate in that it makes the feature of being able to hover over the bookmark less useful than it might be, but this is the way application menus work.
-> WONTFIX?
(In reply to comment #5)
> -> WONTFIX?
dietrich's call
Whiteboard: wontfix?
Whiteboard: wontfix? → wontfix? [DUPEME]
(In reply to comment #4)
> This is normal behavior for menus for all applications under both Windows and
> Linux.
> 
> It is kind of unfortunate in that it makes the feature of being able to hover
> over the bookmark less useful than it might be, but this is the way application
> menus work.

IMHO: 
If we add information to the statusbar we shouldn't cover it,period.
(In reply to comment #7)
> (In reply to comment #4)
> > This is normal behavior for menus for all applications under both Windows and
> > Linux.
> > 
> > It is kind of unfortunate in that it makes the feature of being able to hover
> > over the bookmark less useful than it might be, but this is the way application
> > menus work.
> 
> IMHO: 
> If we add information to the statusbar we shouldn't cover it,period.

IE works exactly the same  way.  It displays the url in the status bar when you hover over an entry in the Favorites menu, yet the menu covers the status bar so you can't read most of it.
> IE works exactly the same  way.  It displays the url in the status bar when you
> hover over an entry in the Favorites menu, yet the menu covers the status bar
> so you can't read most of it.

I know, IE does it equally wrong, which shouldn't be a reason for us to do it too.
We shouldn't cover the url's in the statusbar and certainly not the ones from live bookmarks.

Comment 10

9 years ago
FWIW, I'm seeing this on Shiretoko, too.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090514 Shiretoko/3.5b5pre - Build ID: 20090514043924
I'm not sure what the big deal is with this.  The status bar information is merely a duplicate of information that appears in the tooltip anyway.

Comment 12

8 years ago
I say that this is a WONTFIX, as the fact that you can resize the window in a way that you just could not display a menu. If there is a problem with tooltips not showing up every time, then that is what should be fixed. I don't like the idea of making the menus shorter just to see the status bar.
(In reply to comment #7)
> If we add information to the statusbar we shouldn't cover it,period.

This is not a reason to shorten the menu. It is a reason to *not* put the URL of the bookmark in the status bar. As others mentioned, the URL is still available via the tooltip, which is more contextually appropriate anyways.

-> WONTFIX
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix? [DUPEME] → [DUPEME]
In Windows, I have my task bar set to be ON TOP OF OTHER WINDOWS. Firefox should respect this and NOT cover up my task bar. :)
(In reply to comment #14)
> In Windows, I have my task bar set to be ON TOP OF OTHER WINDOWS. Firefox
> should respect this and NOT cover up my task bar. :)

All windows programs including the start menu cover the task bar in this situation.
I don't see my start menu covering it, but then again I don't have 29387489234 million things in my start menu. :) Oh well. I'll shut up now.

Updated

8 years ago
Status: RESOLVED → VERIFIED
(In reply to comment #16)
> I don't see my start menu covering it, but then again I don't have 29387489234
> million things in my start menu. :) Oh well. I'll shut up now.

you need to go to program or all programs -> programs depending on your settings
or windows version and taskbar settings.  Anyway unless you have very few
programs installed, it covers the taskbar completely and the titlebar of a
fullscreen app by about 1/3. (assuming you have the taskbar at screen bottom).
You need to log in before you can comment on or make changes to this bug.