If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Editing/Replacing words in text input box reverts to last value on [tab]

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: miketosh, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-01])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

I have 'Remember what I enter in forms and search bar' turned on, and when I go to Google and search multiple times, on subsequent searches, I have difficulty modifying what is in the search field.  This is affected by the key sequence or the direction of the mouse after I hightlight a word to replace.

Reproducible: Always

Steps to Reproduce:
1. Turn on Remember what I've typed in Forms option
2. Go to Google, and type in 3 or more words into the search box
3. Click Search
4. In the Search box, double click on one of the first words to highlight it, then drag the mouse down out of the way.  At this point, the suggestion box should appear, and the last searched value is now displayed.
5. Type a new word to replace the highlighted one, and hit tab.
Actual Results:  
After all of this, the search box reverts to the last saved value even though I've typed new words

Expected Results:  
The new words should show in my search.
(Reporter)

Comment 1

9 years ago
Oh, and it is quite annoying, as this is my normal way to modify searches and form entries.
This is a mass search for bugs which are in the Firefox General component, are
UNCO, have not been changed for 500 days and have an unspecified version. 

Reporter, can you please update to Firefox 3.6.10 or later, create a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles, and test again. If you still see the issue, please update this bug. If the issue is gone, please set the status to RESOLVED > WORKSFORME.
Whiteboard: [CLOSEME 2010-11-01]
(Reporter)

Comment 3

7 years ago
Cannot reproduce on other sites, and the changes to Google's site rule out the original test case.

Perhaps this could have been a Google bug in the first place.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.