libsydneyaudio compile problem on Mac OS X (particularly 10.6)

RESOLVED FIXED

Status

()

Core
Audio/Video
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Josh Aas, Assigned: Josh Aas)

Tracking

Trunk
x86_64
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

3.13 KB, patch
Details | Diff | Splinter Review
(Assignee)

Description

9 years ago
Created attachment 376438 [details] [diff] [review]
fix v1.0

"libsydneyaudio" uses things like "ComponentDescription" but doesn't include all the necessary headers (CoreServices). Looks like we get away with it on <= 10.5 but not on 10.6.

I assume we pull this code in from somewhere, we should upstream any fix.
Attachment #376438 - Flags: review?(chris.double)
(Assignee)

Updated

9 years ago
Blocks: 468509

Comment 1

9 years ago
Comment on attachment 376438 [details] [diff] [review]
fix v1.0

Thanks, I'll organise upstreaming it. In the meantime can you add a note to README_MOZILLA referencing this bug, and include the patch file in the directory so I don't overwrite it in the next libsydneyaudio update if it hasn't been upstreamed by then. You'll see similar patches there that haven't been upstreamed yet.
Attachment #376438 - Flags: review?(chris.double) → review+
(Assignee)

Comment 2

9 years ago
Created attachment 378078 [details] [diff] [review]
fix v1.1

Adds the patch to the tree, document in README.
Attachment #376438 - Attachment is obsolete: true
(Assignee)

Comment 3

9 years ago
pushed to mozilla-central

http://hg.mozilla.org/mozilla-central/rev/998d6f6e95b7
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.