Filter&Search UI: Fewer button doesn't work

VERIFIED WORKSFORME

Status

MailNews Core
Filters
P4
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: chuang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][PDTP4])

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Using aug15 commercial m18 build

The Fewer button to remove the last criteria line doesn't enable when editing an
existing filter ( however, if you click the disabled button it does work).

1.  Go to mail window, Edit|Message filters.
2.  Click New.  Create a filter with two criteria lines, confirm OK.
3.  Select the filter in the main filter dialog's list and click Edit. Note the
Fewer button is disabled, no matter where the focus in the dialog. Click the
disabled button -- it does work.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 1

18 years ago
*** Bug 50073 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
mail triage reviewing untargetted bugs
going to put this on the nsbeta3, mail6 list for SusEng to help.
Keywords: mail6, nsbeta3
Whiteboard: [nsbeta3-]
Target Milestone: --- → M18
(Reporter)

Comment 3

18 years ago
This has morphed... fewer button is worse now, no functionality at all.

Using aug24 commercial build in both search and filter ui:
Fewer button never works, even if enabled.  (Bad!)  
Users would have to delete filter or close search and start again.

We need to fix this for beta3, please reconsider. Removing nsbeta3-
Whiteboard: [nsbeta3-]
(Reporter)

Updated

18 years ago
Summary: Filter UI: Fewer button doesn't enable for edit existing filter → Filter&Search UI: Fewer button doesn't work

Comment 4

18 years ago
+, P2 per mail triage.  

We should make the button work although as a last minute fix, we could remove 
the button.  However, that would make it harder to create/edit filters.
Severity: normal → major
Keywords: mail6 → mail4
Priority: P3 → P2
Whiteboard: [nsbeta3+]

Comment 5

18 years ago
hah, turns out this was absurdly simple - for some reason trying to dump() a 
tree row was throwing an exception and that was preventing the rest of the 
onLess() button from firing.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

18 years ago
Using aug29 commercial build.
Now the fewer button works when adding a new filter, but we're back to the
original condition described -- fewer button doesn't enable when editing
existing filter.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

18 years ago
Take it from Alec, reassign to myself.
Assignee: alecf → chuang
Status: REOPENED → NEW

Comment 8

18 years ago
PDT thought this should be a P4, as it is too easy to work-around (hit the 
button).
Priority: P2 → P4
Whiteboard: [nsbeta3+] → [nsbeta3+][PDTP4]
(Assignee)

Comment 9

18 years ago
Created attachment 14050 [details] [diff] [review]
Patch for the fix
(Assignee)

Comment 10

18 years ago
Created attachment 14051 [details] [diff] [review]
A new patch without the dump statement

Comment 11

18 years ago
r=alecf
(Assignee)

Comment 12

18 years ago
I had the fix when it was still a P2.  Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

18 years ago
OK using sep7 commercial build with linux rh6.0, NT 4.0 and Mac OS 9.0
Status: RESOLVED → VERIFIED

Comment 14

17 years ago
ADD "REGRESSION" TO THE KEYWORDS!
This one seems to keep coming back: see also bug# 50435, and I suspect more.
This summary has a better description. Note that the "More" button also doesn't
work.
Not only does the "fewer" button not work,nor does the "more" button.
Tested under both solaris & windows, using mozilla v0.6.
I can initially create a filter with more than 1 rule.
However, when I edit an existing filter, I can neither add (more) nor delete
(fewer) rules. What happens is that the "OK" button refuses to respond; the only
option is to cancel.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 15

17 years ago
Both More and Fewer work for me on existing filters, and can save the edited
filter on OK.
I'm using 20001-01-12  commercial trunk builds win98, linux rh6.0 and mac os 9.0.

OK to editing existing filters has been working for me since bug 60904 was fixed
in December.

What's the build ID you're using? 
(Reporter)

Comment 16

17 years ago
Marking worksforme as of jan16 commercial trunk builds.
Reporter, if you find this still is a problem with a more current build, let us
know.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 17

17 years ago
Marking verified (worksforme)
Status: RESOLVED → VERIFIED

Comment 18

17 years ago
This was broken in v0.6, but is fixed in NT4.0's v0.7.
This is still broken in M18, which is the latest solaris 2.5 binary.
I cannot get solaris v0.7 to build, as it complains about accessing /dev/zero
during compilation. Hopefully, there is a bug report for that.
Thus, solaris remains untested.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.