If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"ASSERTION: Shouldn't be trying to restyle non-elements directly" with colgroup

RESOLVED FIXED

Status

()

Core
Layout: Tables
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Jesse Ruderman, Assigned: bz)

Tracking

(Blocks: 1 bug, {assertion, regression, testcase})

Trunk
x86
Mac OS X
assertion, regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

226 bytes, application/xhtml+xml
Details
(Reporter)

Description

9 years ago
Created attachment 376490 [details]
testcase

###!!! ASSERTION: Shouldn't be trying to restyle non-elements directly: '!aContent || aContent->IsNodeOfType(nsINode::eELEMENT)', file /Users/jruderman/central/layout/base/nsStyleChangeList.cpp, line 96
This is sort of a regression from bug 490173.  In this case, the textnode's display is not none, but the frame is suppressed inside the colgroup, so we have an undisplayed content entry for that node.  

I could do some more work inside the frame constructor to detect this case and not create an undisplayed content entry if we're being suppressed due entirely to our parent and not our own style data, but it would make more sense to me to not assert in nsStyleChangeList if the restyle is a frame reconstruct, since that makes sense for non-elements.

David, any objections to the latter?
Blocks: 490173
Flags: blocking1.9.2?
Depends on: 492163
Assignee: nobody → bzbarsky
Status: NEW → ASSIGNED
Pushed a crashtest and fix for this as part of http://hg.mozilla.org/mozilla-central/rev/ae03e9085759
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Flags: blocking1.9.2?
You need to log in before you can comment on or make changes to this bug.