When using "Edit as new" in draft of template folder of non-primary account, wrong identity is selected

RESOLVED DUPLICATE of bug 279846

Status

RESOLVED DUPLICATE of bug 279846
10 years ago
8 years ago

People

(Reporter: mp26+moz, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.10) Gecko/2009043022 Gentoo Firefox/3.0.10
Build Identifier: version 2.0.0.21 (20090328)

When I use "Edit as new ..." in the context menu of a message in the folders "Draft" or "Template" of a non-primary IMAP account, the default identity for sending the message is set to the primary identity and not the one for the message.

It works correctly though for mail in other folders, e.g., the "Sent" folder


Reproducible: Always

Steps to Reproduce:
1. go into the drafts folder of a non-primary imap account, say "account B"
2. right click on a message, select "Edit as new ..."

(account A is the primary one, B a secondary)
Actual Results:  
"From" shows "account A" and not "account B"

Expected Results:  
"From" should show "account B"

(this works if "Edit as new ..." is called on a message from another folder, e.g., "Sent")

Maybe related to bug #414221

I'm assigning it normal prio, as its easy to route confidential information through a wrong account ...
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0
Which case?

(Case-1) Draft mail created by Tb, using From: for an identity,
         and copied(or moved) to an account's Drafts folder.
         => X-Identity-Key: header by Tb exists.
(Case-1-A) ID in X-Identity-Key: is define by Tb,
           at where "Edit As New(or "Edit") is executed.
(Case-1-B) ID in X-Identity-Key: is NOT define by Tb,
           at where "Edit As New(or "Edit") is executed.
           (If saved to Drafts by Tb-1 and edited by Tb-2,) 
           (this situation can occur.)

(Case-2) Mail downloaded by Tb from IMAP server(or imported from other mailer),
         and copied(or moved) to an account's Drafts folder.
         => X-Identity-Key: header doesn't exist.

> not the one for the message.

What do you mean?
  - Preset From: address upon "Edit (As New)" is different from
    mail address for identity saved in X-Identity-Key: header? 
  - Preset From: address upon "Edit (As New)" is different from
    mail address for main identity of account who owns the Drafts folder?
  - Preset From: address upon "Edit (As New)" is different from
    From: header of main data in Drafts folder?
(Reporter)

Comment 2

10 years ago
It's case 1-B, in TB-1 the account corresponds to "id1" and in TB-2 the account has "id7" (and if edit-as-new is used, it is edited for the account which locally has "id1").

This does not happen in other folders, as mails there don't have the X-Identity-Key header.

So the real bug is, that account ids are locally defined (per TB profile) but used for storing global stuff (e.g., identities in IMAP folders).

Why not store the whole email address in the X-Identity-Key header instead of the local IDs?
(Reporter)

Comment 3

10 years ago
> What do you mean?
[...]
>  - Preset From: address upon "Edit (As New)" is different from
>    mail address for main identity of account who owns the Drafts folder?

This one.
Same issue as bug 279846?
(if you feel bug summary of 279846 is not so good for search by you, modify it, please)
(Reporter)

Comment 5

10 years ago
This bug is similar to scenario 2 from bug #279846.
(In reply to comment #5)
> similar to scenario 2 from bug #279846.

Does it mean DUP of bug 279846? If not, what is difference form bug 279846?
(Reporter)

Comment 7

10 years ago
This bug here describes a sub-problem of the one from bug #279846.

If you want to split up the other one into two, this here would be one half.  If not, this one here is kind of a dup.
I don't think we need to keep separate bugs for two cases in 279846. Duping.

By the way, do you think bug summary of 279846 is good for your search? If you feel not-so-good, please modify it for future victims of the bug, please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 279846
You need to log in before you can comment on or make changes to this bug.