Closed Bug 492133 Opened 11 years ago Closed 11 years ago

Minefield refuses to remember scroll positions above an arbitrary threshold (on certain pages)

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

VERIFIED DUPLICATE of bug 491842

People

(Reporter: fehe, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090507 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090507 Minefield/3.6a1pre

When switching back to a tab loaded with a certain page, after launching a link off that page, the browser automatically scrolls down to a certain arbitrary position and will not remember any scroll position higher than that position.  It will, however, remember scroll positions lower than that arbitrary position.

This is a regression as follows:

Works properly (remember any position):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090505 Minefield/3.6a1pre ID:20090505041741

Fails (scrolls down):
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090506 Minefield/3.6a1pre ID:20090506045618

I suspect Bug 67752 may be the culprit


Reproducible: Always

Steps to Reproduce:
1. Visit the linked URL
2. Pause the video and scroll down till you see the "View all 21 comments" link
3. Middle-click "View all 21 comments" to open in a new tab.
4. Scroll the video page all the way back up.
5. Switch to the new tab from Step 3
6. Switch back to the tab containing the video.
7. Notice that the page scrolled down by itself
Component: General → Layout
Product: Firefox → Core
Version: unspecified → Trunk
Keywords: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Confirmed - Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090508 Minefield/3.6a1pre
It's not scrolling down to an arbitrary position; it's scrolling down just far enough to put that link you clicked at the bottom of the viewport.  :)

In any case, this is a duplicate of bug 491842 (and the patch there fixes the issue).  I really appreciate the clear steps to reproduce; they made it very easy to check what's going on and to test it against several test builds here!
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 491842
Ok thanks.
Resolution: DUPLICATE → FIXED
Resolution: FIXED → DUPLICATE
Duplicate of bug: 491842
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.