Weave 0.3.2 deleted all my data

RESOLVED FIXED

Status

Cloud Services
General
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: henrik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090401 Ubuntu/9.04 (jaunty) Shiretoko/3.5b4pre
Build Identifier: 0.3.2

On a fresh Firefox install, I installed weave 0.3.0.  I didn't get any bookmarks or passwords, so I upgrade to 0.3.2 since that is the version installed on my other computers.  Still no bookmarks.  When I look at the log, I see that Weave deleted all the data on the server.


Reproducible: Always




Log file:

2009-05-10 11:51:24	Service.Main         INFO	Logs reinitialized for service reset
2009-05-10 11:51:24	Service.Main         DEBUG	Event: weave:service:reset-service:finish
2009-05-10 11:51:24	Engine.Clients       DEBUG	Event: weave:engine:reset-client:start
2009-05-10 11:51:24	Engine.Clients       DEBUG	Resetting clients last sync time
2009-05-10 11:51:24	Store.Clients.Store  DEBUG	Loading json from disk: weave/meta/clients.json
2009-05-10 11:51:24	Store.Clients.Store  DEBUG	Setting client 5d629a1d-1025-4a65-9a53-6b11b3841231: {"name":"kohjinsha","type":"laptop"}
2009-05-10 11:51:24	Store.Clients.Store  DEBUG	Saving json to disk: weave/meta/clients.json
2009-05-10 11:51:24	Store.Clients.Store  DEBUG	Wiping local clients store
2009-05-10 11:51:24	Store.Clients.Store  DEBUG	Saving json to disk: weave/meta/clients.json
2009-05-10 11:51:24	Engine.Clients       DEBUG	Event: weave:engine:reset-client:finish
2009-05-10 11:51:24	Service.Main         DEBUG	Event: weave:service:reset-client:finish
2009-05-10 11:51:24	Service.Main         INFO	Reset client data from freshStart.
2009-05-10 11:51:24	Service.Main         INFO	Client metadata wiped, deleting server data
2009-05-10 11:51:25	Service.Main         DEBUG	Event: weave:service:wipe-server:start
2009-05-10 11:51:26	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/
2009-05-10 11:51:26	Net.Resource         DEBUG	GET request successful (200)
2009-05-10 11:51:27	Net.Resource         DEBUG	DELETE request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/bookmarks
2009-05-10 11:51:27	Net.Resource         DEBUG	DELETE request successful (200)
2009-05-10 11:51:27	Net.Resource         DEBUG	DELETE request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/clients
2009-05-10 11:51:27	Net.Resource         DEBUG	DELETE request successful (200)
2009-05-10 11:51:28	Net.Resource         DEBUG	DELETE request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto
2009-05-10 11:51:28	Net.Resource         DEBUG	DELETE request successful (200)
2009-05-10 11:51:29	Net.Resource         DEBUG	DELETE request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys
2009-05-10 11:51:29	Net.Resource         DEBUG	DELETE request successful (200)
2009-05-10 11:51:30	Net.Resource         DEBUG	DELETE request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/meta
2009-05-10 11:51:30	Net.Resource         DEBUG	DELETE request successful (200)
2009-05-10 11:51:31	Net.Resource         DEBUG	DELETE request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/passwords
2009-05-10 11:51:31	Net.Resource         DEBUG	DELETE request successful (200)
2009-05-10 11:51:31	Service.Main         DEBUG	Event: weave:service:wipe-server:finish
2009-05-10 11:51:31	Service.Main         DEBUG	Uploading new metadata record
2009-05-10 11:51:31	Service.Main         DEBUG	Setting meta payload storage version to 0.3.2
2009-05-10 11:51:34	Net.Resource         DEBUG	PUT request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/meta/global
2009-05-10 11:51:34	Net.Resource         DEBUG	PUT request successful (200)
2009-05-10 11:51:34	Service.Main         INFO	Server data wiped to ensure consistency after client upgrade ( -> 0.3.2)
2009-05-10 11:51:34	PubKeyManager        TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-10 11:51:35	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-10 11:51:35	Net.Resource         DEBUG	GET request failed (404)
2009-05-10 11:51:35	Net.Resource         DEBUG	Error response: 
"record not found"
2009-05-10 11:51:35	PubKeyManager        DEBUG	Failed to import record: Could not GET resource https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey (404)
2009-05-10 11:51:35	Service.Main         DEBUG	Could not get public key
2009-05-10 11:51:35	PubKeyManager        DEBUG	Generating RSA keypair
2009-05-10 11:51:44	PubKeyManager        DEBUG	Generating RSA keypair... done
2009-05-10 11:51:45	Net.Resource         DEBUG	PUT request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-10 11:51:45	Net.Resource         DEBUG	PUT request successful (200)
2009-05-10 11:51:46	Net.Resource         DEBUG	PUT request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/privkey
2009-05-10 11:51:46	Net.Resource         DEBUG	PUT request successful (200)
2009-05-10 11:51:46	Service.Main         DEBUG	Refreshing client list
2009-05-10 11:51:46	Engine.Clients       DEBUG	Event: weave:engine:sync:start
2009-05-10 11:51:46	Engine.Clients       DEBUG	Ensuring server crypto records are there
2009-05-10 11:51:46	RecordMgr            TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto/clients
2009-05-10 11:51:47	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto/clients
2009-05-10 11:51:47	Net.Resource         DEBUG	GET request successful (200)
2009-05-10 11:51:47	Engine.Clients       INFO	First sync, uploading all items
2009-05-10 11:51:47	ClientTracker        DEBUG	Clearing changed ID list
2009-05-10 11:51:47	ClientTracker        DEBUG	Saving json to disk: weave/changes/clients.json
2009-05-10 11:51:47	Engine.Clients       INFO	1 outgoing items pre-reconciliation
2009-05-10 11:51:47	Engine.Clients       DEBUG	Downloading & applying server changes
2009-05-10 11:51:48	Collection           DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/clients/?full=1&sort=depthindex
2009-05-10 11:51:48	Collection           DEBUG	GET request successful (200)
2009-05-10 11:51:48	Store.Clients.Store  DEBUG	Updating client dcb7250b-49f1-4542-921e-1b21ac9bccbf
2009-05-10 11:51:48	Store.Clients.Store  DEBUG	Saving json to disk: weave/meta/clients.json
2009-05-10 11:51:48	Engine.Clients       INFO	Applied 1 records, reconciled 0 records
2009-05-10 11:51:48	Engine.Clients       DEBUG	Preparing 1 outgoing records
2009-05-10 11:51:48	Engine.Clients       INFO	Uploading 1 records + 0 index/depth records)
2009-05-10 11:51:48	Collection           DEBUG	POST request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/clients/
2009-05-10 11:51:48	Collection           DEBUG	POST request successful (200)
2009-05-10 11:51:48	ClientTracker        DEBUG	Clearing changed ID list
2009-05-10 11:51:48	ClientTracker        DEBUG	Saving json to disk: weave/changes/clients.json
2009-05-10 11:51:48	Engine.Clients       DEBUG	Finishing up sync
2009-05-10 11:51:48	Engine.Clients       DEBUG	Event: weave:engine:sync:finish
2009-05-10 11:51:48	Service.Main         INFO	Sync completed successfully
2009-05-10 11:51:48	Service.Main         DEBUG	Event: weave:service:sync:finish
2009-05-10 11:52:27	Service.Main         DEBUG	Event: weave:service:sync:start
2009-05-10 11:52:27	Service.Main         DEBUG	Fetching global metadata record
2009-05-10 11:52:27	RecordMgr            TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/meta/global
2009-05-10 11:52:28	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/meta/global
2009-05-10 11:52:28	Net.Resource         DEBUG	GET request successful (200)
2009-05-10 11:52:28	Service.Main         DEBUG	Min supported storage version is 0.3.2
2009-05-10 11:52:28	Service.Main         DEBUG	Remote storage version is 0.3.2
2009-05-10 11:52:28	PubKeyManager        TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-10 11:52:28	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-10 11:52:28	Net.Resource         DEBUG	GET request successful (200)
2009-05-10 11:52:28	PrivKeyManager       TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/privkey
2009-05-10 11:52:29	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/privkey
2009-05-10 11:52:29	Net.Resource         DEBUG	GET request successful (200)
2009-05-10 11:52:29	Service.Main         DEBUG	Refreshing client list
2009-05-10 11:52:29	Engine.Clients       DEBUG	Event: weave:engine:sync:start
2009-05-10 11:52:29	Engine.Clients       DEBUG	Ensuring server crypto records are there
2009-05-10 11:52:29	Engine.Clients       INFO	0 outgoing items pre-reconciliation
2009-05-10 11:52:29	Engine.Clients       DEBUG	Downloading & applying server changes
2009-05-10 11:52:30	Collection           DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/clients/?newer=1241949110&modified=1241949110&full=1&sort=depthindex
2009-05-10 11:52:30	Collection           DEBUG	GET request successful (200)
2009-05-10 11:52:30	Engine.Clients       INFO	Applied 0 records, reconciled 0 records
2009-05-10 11:52:30	Engine.Clients       DEBUG	Preparing 0 outgoing records
2009-05-10 11:52:30	ClientTracker        DEBUG	Clearing changed ID list
2009-05-10 11:52:30	ClientTracker        DEBUG	Saving json to disk: weave/changes/clients.json
2009-05-10 11:52:30	Engine.Clients       DEBUG	Finishing up sync
2009-05-10 11:52:30	Engine.Clients       DEBUG	Event: weave:engine:sync:finish
2009-05-10 11:52:30	Service.Main         INFO	Sync completed successfully
2009-05-10 11:52:30	Service.Main         DEBUG	Event: weave:service:sync:finish

Comment 1

9 years ago
When weave upgrades, it deletes things on the server because the way it stores data might be incompatible with previous versions.

Is your local data still there? How about the other machine? If you resync there, are you able to get your bookmarks, etc?

Comment 2

9 years ago
This seems like a bug, though:

2009-05-10 11:51:34    Service.Main         INFO    Server data wiped to ensure
consistency after client upgrade ( -> 0.3.2)

remoteVersion is blank somehow.  sdwilsh had the same problem yesterday, an upgrade "fixed" it.
(Reporter)

Comment 3

9 years ago
OK, I'm back at my work computer.  This computer had Weave 0.3.1 on it when I arrived today, and I upgraded it to 0.3.2.  Weave doesn't seem to wipe the local data, but the activity icon has been spinning for hours now.  Nothing seems to be updated.  Here's the log:

2009-05-11 08:16:25	Service.Main         INFO	Logs reinitialized for service reset
2009-05-11 08:16:25	Service.Main         DEBUG	Event: weave:service:reset-service:finish
2009-05-11 08:16:25	Engine.Clients       DEBUG	Event: weave:engine:reset-client:start
2009-05-11 08:16:25	Engine.Clients       DEBUG	Resetting clients last sync time
2009-05-11 08:16:25	Store.Clients.Store  DEBUG	Loading json from disk: weave/meta/clients.json
2009-05-11 08:16:25	Store.Clients.Store  DEBUG	Setting client dcb7250b-49f1-4542-921e-1b21ac9bccbf: {"name":"jobbmac","type":"desktop"}
2009-05-11 08:16:25	Store.Clients.Store  DEBUG	Saving json to disk: weave/meta/clients.json
2009-05-11 08:16:25	Store.Clients.Store  DEBUG	Wiping local clients store
2009-05-11 08:16:25	Store.Clients.Store  DEBUG	Saving json to disk: weave/meta/clients.json
2009-05-11 08:16:25	Engine.Clients       DEBUG	Event: weave:engine:reset-client:finish
2009-05-11 08:16:26	Engine.Bookmarks     DEBUG	Event: weave:engine:reset-client:start
2009-05-11 08:16:26	Engine.Bookmarks     DEBUG	Resetting bookmarks last sync time
2009-05-11 08:16:26	Engine.Bookmarks     DEBUG	Event: weave:engine:reset-client:finish
2009-05-11 08:16:26	Engine.Forms         DEBUG	Event: weave:engine:reset-client:start
2009-05-11 08:16:26	Engine.Forms         DEBUG	Resetting forms last sync time
2009-05-11 08:16:26	Engine.Forms         DEBUG	Event: weave:engine:reset-client:finish
2009-05-11 08:16:26	Engine.History       DEBUG	Event: weave:engine:reset-client:start
2009-05-11 08:16:26	Engine.History       DEBUG	Resetting history last sync time
2009-05-11 08:16:26	Engine.History       DEBUG	Event: weave:engine:reset-client:finish
2009-05-11 08:16:26	Engine.Passwords     DEBUG	Event: weave:engine:reset-client:start
2009-05-11 08:16:26	Engine.Passwords     DEBUG	Resetting passwords last sync time
2009-05-11 08:16:26	Engine.Passwords     DEBUG	Event: weave:engine:reset-client:finish
2009-05-11 08:16:26	Engine.Tabs          DEBUG	Event: weave:engine:reset-client:start
2009-05-11 08:16:26	Engine.Tabs          DEBUG	Resetting tabs last sync time
2009-05-11 08:16:26	Store.Tabs.Store     DEBUG	Loading json from disk: weave/meta/tabSets.json
2009-05-11 08:16:26	Store.Tabs.Store     DEBUG	Wipe called.  Clearing cache of remote client tabs.
2009-05-11 08:16:26	Engine.Tabs          DEBUG	Event: weave:engine:reset-client:finish
2009-05-11 08:16:26	Service.Main         DEBUG	Event: weave:service:reset-client:finish
2009-05-11 08:16:26	Service.Main         INFO	Reset client because of syncID mismatch.
2009-05-11 08:16:26	Service.Main         INFO	Reset the client after a server/client sync ID mismatch
2009-05-11 08:16:26	PubKeyManager        TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-11 08:16:27	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/pubkey
2009-05-11 08:16:27	Net.Resource         DEBUG	GET request successful (200)
2009-05-11 08:16:27	PrivKeyManager       TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/privkey
2009-05-11 08:16:28	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/keys/privkey
2009-05-11 08:16:28	Net.Resource         DEBUG	GET request successful (200)
2009-05-11 08:16:28	Service.Main         DEBUG	Refreshing client list
2009-05-11 08:16:28	Engine.Clients       DEBUG	Event: weave:engine:sync:start
2009-05-11 08:16:28	Engine.Clients       DEBUG	Ensuring server crypto records are there
2009-05-11 08:16:28	RecordMgr            TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto/clients
2009-05-11 08:16:29	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto/clients
2009-05-11 08:16:29	Net.Resource         DEBUG	GET request successful (200)
2009-05-11 08:16:29	Engine.Clients       INFO	First sync, uploading all items
2009-05-11 08:16:29	ClientTracker        DEBUG	Clearing changed ID list
2009-05-11 08:16:29	ClientTracker        DEBUG	Saving json to disk: weave/changes/clients.json
2009-05-11 08:16:29	Engine.Clients       INFO	1 outgoing items pre-reconciliation
2009-05-11 08:16:29	Engine.Clients       DEBUG	Downloading & applying server changes
2009-05-11 08:16:30	Collection           DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/clients/?full=1&sort=depthindex
2009-05-11 08:16:30	Collection           DEBUG	GET request successful (200)
2009-05-11 08:16:30	Store.Clients.Store  DEBUG	Updating client 5d629a1d-1025-4a65-9a53-6b11b3841231
2009-05-11 08:16:30	Store.Clients.Store  DEBUG	Saving json to disk: weave/meta/clients.json
2009-05-11 08:16:30	Engine.Clients       INFO	Applied 1 records, reconciled 1 records
2009-05-11 08:16:30	Engine.Clients       DEBUG	Preparing 1 outgoing records
2009-05-11 08:16:30	Engine.Clients       INFO	Uploading 1 records + 0 index/depth records)
2009-05-11 08:16:31	Collection           DEBUG	POST request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/clients/
2009-05-11 08:16:31	Collection           DEBUG	POST request successful (200)
2009-05-11 08:16:31	ClientTracker        DEBUG	Clearing changed ID list
2009-05-11 08:16:31	ClientTracker        DEBUG	Saving json to disk: weave/changes/clients.json
2009-05-11 08:16:31	Engine.Clients       DEBUG	Finishing up sync
2009-05-11 08:16:31	Engine.Clients       DEBUG	Event: weave:engine:sync:finish
2009-05-11 08:16:31	Engine.Bookmarks     DEBUG	Event: weave:engine:sync:start
2009-05-11 08:16:31	Engine.Bookmarks     DEBUG	Ensuring server crypto records are there
2009-05-11 08:16:31	RecordMgr            TRACE	Importing record: https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto/bookmarks
2009-05-11 08:16:32	Net.Resource         DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/crypto/bookmarks
2009-05-11 08:16:32	Net.Resource         DEBUG	GET request successful (200)
2009-05-11 08:16:32	Engine.Bookmarks     INFO	First sync, uploading all items
2009-05-11 08:16:32	BmkTracker           DEBUG	Clearing changed ID list
2009-05-11 08:16:32	BmkTracker           DEBUG	Saving json to disk: weave/changes/bookmarks.json
2009-05-11 08:16:32	Engine.Bookmarks     INFO	1314 outgoing items pre-reconciliation
2009-05-11 08:16:32	Engine.Bookmarks     DEBUG	Downloading & applying server changes
2009-05-11 08:16:35	Collection           DEBUG	GET request for https://sj-weave01.services.mozilla.com/0.3/user/henrik/bookmarks/?full=1&sort=depthindex
2009-05-11 08:16:37	FormTracker          TRACE	Form submission notification for XXXXXX
2009-05-11 08:16:37	FormTracker          TRACE	charset_test's type is not 'text': hidden
2009-05-11 08:16:37	FormTracker          TRACE	fb_dtsg's type is not 'text': hidden
2009-05-11 08:16:37	FormTracker          TRACE	next's type is not 'text': hidden
2009-05-11 08:16:37	FormTracker          TRACE	version's type is not 'text': hidden
2009-05-11 08:16:37	FormTracker          TRACE	return_session's type is not 'text': hidden
2009-05-11 08:16:37	FormTracker          TRACE	charset_test's type is not 'text': hidden
2009-05-11 08:16:37	FormTracker          TRACE	email's value is the default
2009-05-11 08:16:37	FormTracker          TRACE	pass's type is not 'text': password
2009-05-11 08:16:37	FormTracker          TRACE	persistent's type is not 'text': checkbox
2009-05-11 08:16:37	FormTracker          TRACE	login's type is not 'text': submit
2009-05-11 08:16:38	Collection           DEBUG	GET request successful (200)
2009-05-11 08:16:38	Async.Generator      ERROR	Exception: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [IWeaveCrypto.unwrapSymmetricKey] (JS frame :: file:///Users/henrik/Library/Application%20Support/Firefox/Profiles/ha9z30n1.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/base_records/crypto.js :: CryptoMeta__getKey :: line 178)
2009-05-11 08:16:38	Async.Generator      DEBUG	Async stack trace:
Original exception: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [IWeaveCrypto.unwrapSymmetricKey] (JS frame :: file:///Users/henrik/Library/Application%20Support/Firefox/Profiles/ha9z30n1.default/extensions/%7B340c2bbc-ce74-4362-90b5-7c26312808ef%7D/modules/base_records/crypto.js :: CryptoMeta__getKey :: line 178)
Async stack trace:
module:crypto.js:182 :: CryptoMeta_getKey
module:crypto.js:112 :: CryptoWrap__decrypt
module:util.js:666 :: EL_notify

2009-05-11 08:16:38	Async.Generator      ERROR	Exception caught from onComplete handler of CryptoWrap__decrypt-89 generator
2009-05-11 08:16:38	Async.Generator      ERROR	Exception: Unknown places item object type
2009-05-11 08:16:46	HistoryTracker       TRACE	onVisit: XXXXXX
2009-05-11 08:16:46	HistoryTracker       TRACE	onVisit: XXXXXX
2009-05-11 08:21:23	Service.Main         DEBUG	Skipping scheduled sync: already locked for sync
2009-05-11 08:22:40	FormTracker          TRACE	Form submission notification for XXXXXXXX
2009-05-11 08:22:40	FormTracker          TRACE	charset_test's type is not 'text': hidden
2009-05-11 08:22:40	FormTracker          TRACE	fb_dtsg's type is not 'text': hidden
2009-05-11 08:22:40	FormTracker          TRACE	post_form_id's type is not 'text': hidden
2009-05-11 08:22:40	FormTracker          TRACE	add_comment_text_33118819540650112_81217502629 is not a DOMHTMLInputElement: [object XPCNativeWrapper [object HTMLTextAreaElement]]
2009-05-11 08:22:40	FormTracker          TRACE	submit_comment_33118819540650112_81217502629's type is not 'text': submit
2009-05-11 08:24:55	HistoryTracker       TRACE	onVisit: XXXXXX
2009-05-11 08:24:56	HistoryTracker       DEBUG	Adding changed ID 918c0d85-8f0f-dc4e-aef3-44b5f1fb92e2
2009-05-11 08:24:56	HistoryTracker       DEBUG	Saving json to disk: weave/changes/history.json
2009-05-11 08:25:45	HistoryTracker       TRACE	onVisit: XXXXXX
2009-05-11 08:25:50	HistoryTracker       TRACE	onVisit: XXXXXX
2009-05-11 08:25:51	BmkTracker           TRACE	onItemChanged: 60297, favicon = "XXXXXX"
2009-05-11 08:25:51	BmkTracker           TRACE	onItemChanged: 60281, favicon = "XXXXXXX"
2009-05-11 08:25:51	BmkTracker           TRACE	onItemChanged: 60243, favicon = "XXXXXX"
2009-05-11 08:25:51	BmkTracker           TRACE	onItemChanged: 60237, favicon = "XXXXXX"
2009-05-11 08:25:51	BmkTracker           TRACE	onItemChanged: 519, favicon = "XXXXXXX"
2009-05-11 08:25:54	BmkTracker           TRACE	onItemChanged: 608, favicon = "XXXXXX"
2009-05-11 08:26:04	HistoryTracker       TRACE	onVisit: XXXXXX
2009-05-11 08:26:04	HistoryTracker       DEBUG	Adding changed ID f984fec5-083d-fa40-9732-8a3941225bb3
2009-05-11 08:26:04	HistoryTracker       DEBUG	Saving json to disk: weave/changes/history.json
2009-05-11 08:26:19	HistoryTracker       TRACE	onVisit: XXXXXXXX
2009-05-11 08:26:19	HistoryTracker       DEBUG	Adding changed ID 165771ec-496a-6b45-8a82-263a87cad455
2009-05-11 08:26:19	HistoryTracker       DEBUG	Saving json to disk: weave/changes/history.json
2009-05-11 08:26:23	Service.Main         DEBUG	Skipping scheduled sync: already locked for sync

Comment 4

9 years ago
Please attach such long logs, it makes the comments a bit hard to follow...

Your second log doesn't show anything related to this bug.  The only interesting lines in it are these:

2009-05-11 08:16:38    Async.Generator      ERROR    Exception: Component
returned failure code: 0x80004005 (NS_ERROR_FAILURE)
[IWeaveCrypto.unwrapSymmetricKey] ...

Which generally mean that you mistyped your passphrase, or you have corrupted data on the server (usually due to a mistyped passphrase at some point in the past).

The solution to that problem is to sign out on all computers and re-sign in with the correct passphrase, and if that doesn't fix it to delete server data.

Updated

9 years ago
Flags: blocking-weave1.0+
Target Milestone: -- → 1.0

Updated

9 years ago
Component: Weave → Needs Triage
Flags: blocking-weave1.0+
Product: Mozilla Labs → Weave
Target Milestone: 1.0 → ---
QA Contact: weave → needstriage

Comment 5

8 years ago
We check if you type in the wrong passphrase now on login.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Updated

7 years ago
Component: Needs Triage → General
QA Contact: needstriage → general
You need to log in before you can comment on or make changes to this bug.