TB crashed, when trying to delete email in inbox from standalone message view [@ nsMsgDBView::GetURIForViewIndex]

RESOLVED WORKSFORME

Status

Thunderbird
Message Reader UI
--
critical
RESOLVED WORKSFORME
9 years ago
6 years ago

People

(Reporter: kuegler_david, Unassigned)

Tracking

({crash})

x86
Windows Vista
crash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs trunk test], crash signature)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Thunderbird Version 2.0.0.21 (20090302)

While reading emails in standalone message view (local folders, inbox) deleting the last email (window should close afterwards) causes TB to crash

I had at least 10 incidents in talkback

Reproducible: Sometimes

Steps to Reproduce:
1. open TB
2. open last email in standalone (usally email by ebay)
3. delete
4. crashes (quite often)
Actual Results:  
most the times,
TB crahes and the crash is sent to mozilla

Expected Results:  
close the window

I have no idea about the Module in which it crashes :(
Talkback incidents are
TB54479356Q, TB54457963M, TB54439982X, TB54408034M, TB54303322Z, TB54125935M, TB54103252E, TB54046150W, TB53934149Q, TB53782761E, TB53713889K, TB53678183M
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0
(Reporter)

Comment 1

9 years ago
might be related to 288172 (by Stacktrace)

the not 100% reproducability might be connected to multithreading
(Reporter)

Updated

9 years ago
Summary: TB crashed, when trying to delete the last email in inbox from standalone message view → TB crashed, when trying to delete email in inbox from standalone message view
(Reporter)

Comment 2

9 years ago
Does also crash, when not deleting the last but "any" email.

Comment 3

9 years ago
(In reply to comment #1)
> might be related to bug 288172 (by Stacktrace)

I'll let someone else ponder whether it's dupe.

TB53678183M
nsMsgDBView::GetURIForViewIndex  [mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2069]
nsMsgDBView::GetURIForFirstSelectedMessage  [mozilla/mailnews/base/src/nsMsgDBView.cpp, line 5707]
XPTC_InvokeByIndex  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp, line 102]
XPCWrappedNative::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 2169]
XPC_WN_GetterSetter  [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 1487]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1387]
js_InternalInvoke  [mozilla/js/src/jsinterp.c, line 1481]
js_InternalGetOrSet  [mozilla/js/src/jsinterp.c, line 1552]
js_NativeGet  [mozilla/js/src/jsobj.c, line 3483]
js_Interpret  [mozilla/js/src/jsinterp.c, line 3710]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1406]
nsXPCWrappedJSClass::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1453]
nsXPCWrappedJS::CallMethod  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 468]
SharedStub  [mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp, line 147]
nsEventListenerManager::HandleEventSubType  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1655]
Keywords: crash
Summary: TB crashed, when trying to delete email in inbox from standalone message view → TB crashed, when trying to delete email in inbox from standalone message view [@ nsMsgDBView::GetURIForViewIndex]

Comment 4

8 years ago
kuegler can you test whether you crash using v3?
 http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
 backup your profile before testing

note bug 288172 comment 27
Whiteboard: [needs trunk test]
(Reporter)

Comment 5

8 years ago
Hi,

I tested (and will continue to test) the bug with tb3.0rc1 but have not encountered any crashes so far.

I used a script to try to come up with the error. Can someone confirm the error with tb2.0?
I already migrated to tb3.0rc1 and have not yet had the bug again.

script:
with regards to bug 288172

http://khoch2.de/bugs/sendemail.php?to=[youremailaddress] and follow instructions

try to delete the email, while the image is still loading, you might have to permanently allow tb to load external file by bugs@khoch2.de
kuegler then continuing to use TB 3.x confirms that the issue is solved?
Whiteboard: [needs trunk test] → [needs trunk test][closeme 2010-06-21]
(Reporter)

Comment 7

8 years ago
I have not had the issue since then, but on the other hand it used to happen with ebay search emails, and I disabled that because I am not looking for anything right now.
But as of now, I cannot confirm the bug any more.
Ok thanks for feedback: then I close as WFM for now. 

Feel free to reopen it if happens again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [needs trunk test][closeme 2010-06-21] → [needs trunk test]

Updated

8 years ago
Resolution: INCOMPLETE → WORKSFORME
(Assignee)

Updated

6 years ago
Crash Signature: [@ nsMsgDBView::GetURIForViewIndex]
You need to log in before you can comment on or make changes to this bug.