Update QMO stage/production servers to pull from correct locations in SVN

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
--
critical
RESOLVED FIXED
9 years ago
3 years ago

People

(Reporter: paulc, Assigned: chizu)

Tracking

Details

(URL)

(Reporter)

Description

9 years ago
The QMO repository is currently set up such that the production server is at branches/qmo2.
This needs to be moved to tags/production (as we usually have it)
Component: Website → Server Operations
Product: quality.mozilla.org → mozilla.org
QA Contact: website → mrz
Summary: Update production server to pull from tags/production in SVN → Update QMO production server to pull from tags/production in SVN
Version: unspecified → other
(Reporter)

Comment 1

9 years ago
Following an IRC conversation with Alex, we also need to resync production and
trunk. It seems trunk is outdated. So after this change we should tag the
current trunk as tags/qmo1, and replace this trunk with production. So, after
this process, trunk should be up to date with the current branches/qmo2, and
the production site should be located at tags/production

I hope I have this right, Alex :) Would we need to do a database update for the
new trunk (staging server) as well, since the trunk files will change quite a
bit?
Anybody know where the stage server for QMO is located (URL)?

I think this is it...
https://quality.authstage.mozilla.com/

... but I don't know the username/password 
(this could pull from LDAP, or have a generic username/password)
(Reporter)

Comment 3

9 years ago
(In reply to comment #2)
user/pass is qmo/quality
(In reply to comment #3)
> (In reply to comment #2)
> user/pass is qmo/quality

thanks.  This could be posted with the HTTP AUTH login message, I think.

It looks like the stage site pulls from branches/qmo2,
(IT, can you verify this please?), so this is a good place to start.

The process should be something like...

1) move trunk -> tags/qmo1_trunk_051109
2) move branches/qmo2 -> trunk
3) IT will need to update stage to pull from trunk, and migrate any local files (e.g. settings.php, uploaded files, etc)

The process will be nearly the same for moving from trunk -> tags/production
Summary: Update QMO production server to pull from tags/production in SVN → Update QMO stage/production servers to pull from correct locations in SVN
(Assignee)

Updated

9 years ago
Assignee: server-ops → thardcastle
(Reporter)

Comment 5

9 years ago
Bumping this up as it's blocking development.
Severity: major → critical
(In reply to comment #4)
> 1) move trunk -> tags/qmo1_trunk_051109
> 2) move branches/qmo2 -> trunk

This sounds like something webdev needs to do, not IT, correct?

Has this been done yet?
(Reporter)

Comment 7

9 years ago
(In reply to comment #4)
> (IT, can you verify this please?), so this is a good place to start.
Is this confirmed then? I will do the svn moves after.
(Reporter)

Comment 8

9 years ago
Chizu, if I do the move now will you be able to update stage today, so that it's not down over the weekend?

Also, could you tell me what each server pulls from?

E.g. does stage pull from trunk? Or somewhere else? Production I would guess pulls from branches/qmo2

I suppose tagging and moving production can be done anyway (since those require a push to break if not set up), but I'd prefer not to break stage.
(Assignee)

Comment 9

9 years ago
(In reply to comment #8)
> Chizu, if I do the move now will you be able to update stage today, so that
> it's not down over the weekend?
Yes, I can do the switch today.

> Also, could you tell me what each server pulls from?
Stage and Production -> http://svn.mozilla.org/projects/quality.mozilla.org/branches/qmo2
Status: NEW → ASSIGNED
(Reporter)

Comment 10

9 years ago
Thanks!
I'll do the move right now and post again when I'm done. Then you should update:
* production to pull from tags/production
* stage to pull from trunk

How often is stage set up to update? And how? I think on SUMO, for example, it's set to update every 10 minutes or so.
(Reporter)

Comment 11

9 years ago
Moved trunk to tags/qmo1_051509 - r25801
Copied branches/qmo2 to trunk - r25805

Ideally after this, trunk will be an exact copy of production (as production is currently)
Chizu: we should update stage to pull from trunk now and make sure it works. The settings file should be present in trunk/sites/default/settings.php, but should not be under svn.

If the process goes well but the site has errors, we might need to copy the database over from production, as well, and back up the existing one just in case - not sure if that needs to be done by IT, you would know.
(Assignee)

Comment 12

9 years ago
Stage is pulling from trunk now and updates every ten minutes via cron.
(Reporter)

Comment 13

9 years ago
Moved branches/qmo2 to tags/production - r25807-9 (did some renaming multi-step to avoid conflicts)

Need to update production to pull from tags/production. Hopefully all will be fine on next push :)
(Assignee)

Comment 14

9 years ago
Production is now on the production tag.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
woot!  thanks guys, this is awesome
(Reporter)

Comment 16

9 years ago
Yes thanks Chizu! And thanks to you too Alex!
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.