Visibly indicate whether a page is valid HTML/XHTML

UNCONFIRMED
Unassigned

Status

()

Firefox
General
--
enhancement
UNCONFIRMED
9 years ago
8 years ago

People

(Reporter: Martin Walch, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix?)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (compatible; Konqueror/4.2; Linux) KHTML/4.2.3 (like Gecko)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; de; rv:1.9.0.10) Gecko/2009050214 Gentoo Iceweasel/3.0.10

Please add a visible marker in Firefox, indicating whether a page is valid HTML/XHTML or not. Something small, but clearly visible like the yellow star for bookmarking a page.

The big majority of web pages claim to be HTML or XHTML by sending out a Content-Type like text/html or by starting the page with a DOCTYPE. They claim to use w3 standards. But this is a lie. They use broken HTML editors, broken HTML libraries and write something that ressembles HTML. But that is no HTML. That are proprietary, undocumented variants of HTML and they are very bad for the world wide web, as they make it hard to write and maintain HTML engines for everyday use. They can cause totally different rendering in different standards-compliant web browsers and they make it hard to parse those pages and act as a barrier for any kind of processing, like screen-reading.

Firefox can make people fix their pages by indicating whether a website is valid HTML/XHTML. There is a chance that they will care as soon as everyone instantly sees an evaluation of the technical quality of a web page.

Reproducible: Always

Comment 1

9 years ago
This would require Firefox to send each page visited to the w3's html validation service.
Whiteboard: wontfix?
I think the majority of the browser users are not interested in code (it's just a toy to browse) and it can even be annoying to see such cryptic messages appear on the statusbar. 
But maybe a link to W3C in Page Info could be helpful. Although, a bookmarklet is easier.
(Reporter)

Comment 3

9 years ago
(In reply to comment #1)
> This would require Firefox to send each page visited to the w3's html
> validation service.

It is about the specifications of the w3c, which are independant from their website. The W3C Markup Validator is free and open source software and there are more validators beside that one. You could take one of them. But they are not needed. Firefox itself is an HTML parser, knowing the specifications. It can check locally whether a document is valid HTML.

(In reply to comment #2)
> I think the majority of the browser users are not interested in code (it's just
> a toy to browse) and it can even be annoying to see such cryptic messages
> appear on the statusbar. 
> But maybe a link to W3C in Page Info could be helpful. Although, a bookmarklet
> is easier.

There is no need to bother people with cryptic messages. The only message that is needed is whether a page is "valid" or "not valid", like a certificate is valid or not, or a bookmark is set or not.

Browser users should be interested in valid HTML, because the free web has started to disapper. Writing a standards compliant HTML engine is not enough for a browser for everyday use, no matter if it is a toy or not. You need to emulate some actually undefined behavior with some sort of reverse engineering.

Comment 4

8 years ago
See this Firefox Add-On:

Html Validator
https://addons.mozilla.org/de/firefox/addon/249
Project's website: http://users.skynet.be/mgueury/mozilla/

It does exactly, what this bug ist about.

It is based on Tidy (http://tidy.sourceforge.net/) and OpenSP (http://openjade.sourceforge.net/), both also part of the reference validator, the W3C Markup validator (http://validator.w3.org/), the latter of both the most essential part of the validator. For validation of HTML5, the W3C Markup Validator uses/embeds http://html5.validator.nu/.

Remember the possible size of such a solution and its necessary libraries to function correctly and if it might bloat (the size of this Firefox extension currently is approx. 10MB, if HTML5 validation may be included in a future version, the size might increase) and slowdown Firefox eventually, maybe even more, if each website would be checked in realtime and remotely directly against http://validator.w3.org/ instead locally in the browser (and the server capacities of http://validator.w3.org/ are delimited, so that the W3C promotes and recommends to use locally installed validators to relieve their servers).
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> Html Validator
> https://addons.mozilla.org/de/firefox/addon/249
> Project's website: http://users.skynet.be/mgueury/mozilla/

Thank you for this hint. This addon does indeed what I mean. However, it does even much more, like showing a number of errors and a number of warnings, instead of just "valid: yes/no". Also, it is a useful tool for debugging purposes, explaining errors and warnings in detail and more. It is using its own libraries for validation, not the Firefox parser. All this makes this tool rather big and slow.

What I think of, is making some adaptations to Firefox's own parser to always decide whether a document is valid or not. This should not be too hard, because Firefox already has a quirks mode. If it is made sure that quirks mode is activated if and only if the page is not valid HTML/XHTML, such an indicator for valid HTML boils down to be an indicator for whether quirks mode is activ or not.
Users who want this can use the add-on. This is not something we want to add to the default configuration.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX

Updated

8 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---
(Reporter)

Comment 7

8 years ago
Maybe I did not state clear enough what I propose. It is a political thing: I want a big user base to see whether a page is valid HTML/XHTML or not. I want them to ask: "Why is there this red symbol in my browser when I visit that page? What does it mean?" and when seeing an explanation when hovering over it or clicking on it, I want them to ask "Why is the website violating the standards? Is this bad for me?". I want to raise awareness of web standards and I want HTML/XHTML writers to be ashamed of generating broken pages.

This is not about integrating a full featured debugger or to show technical details. That would go beyond the scope of this feature.

This is a political thing, using (or abusing?) the big usage share of Firefox as Webbrowser. Just like supporting MNG, JNG, APNG or SVG or like setting a default search engine or like indicating whether a certificate it trustworthy or not or like supporting Theora, Dirac, WebM, H.264 or other formats in the HTML5 video tag.

Although I think it would be a shame, I understand if you reject this proposal. However, IMO it does not make sense to implement this as an optional feature, because it can only have an impact if it is part of the default Firefox installation.

Thank you for reading. :)
I agree with your goal, but I believe our users don't care about validation, and that they don't need to. To quote WebKit's Maciej Stachowiak <http://lists.w3.org/Archives/Public/www-dom/2005OctDec/0047.html>:

>> The web browser should be a tool for promoting good behavior, not  
>> broken behavior
>
> The web browser should be a tool for browsing the web.

Adding an indication as requested does not help our users browse the web. More importantly, I do not believe that it will actually cause more standards-compliant web pages to be written.
You need to log in before you can comment on or make changes to this bug.