rendering glitches with interactive SVG in FF 3.6a1pre

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090511 Minefield/3.6a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090511 Minefield/3.6a1pre ID:20090511042228

I was playing with these SVG demos and noticed a draw glitch with http://www.croczilla.com/svg/samples/xbl-shapes2/xbl-shapes2.xml .
It doesn't happen with FF 3.0.6.

Reproducible: Always

Steps to Reproduce:
1.  Open http://www.croczilla.com/svg/samples/xbl-shapes2/xbl-shapes2.xml
2.  Click on the top right control point of the spline curve and slowly drag it downwards, then back up.
3.  Watch for redrawing glitches.
Actual Results:  
Moving downwards, at some point the top of the curve does not correctly erase its previous location, leaving a glitch on the screen.  Moving upwards, at some point the top of the curve does not render completely.

Expected Results:  
No rendering glitches.

It's possible there's a bug in the sample SVG, CSS, or XBL, but I can't reproduce the glitch in Firefox 3.0.6.
(Reporter)

Comment 1

9 years ago
Created attachment 376875 [details]
screen shot showing rendering glitch and moved control point
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090512

I was able to reproduce it but only one time.
Status: UNCONFIRMED → NEW
Ever confirmed: true
This should be fixed on trunk with the landing of bug 493079
I did see this before too but bug 493079 does seem to have fixed it.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Depends on: 493079
Duplicate of this bug: 490280
You need to log in before you can comment on or make changes to this bug.