Standalone Message reader window sometimes closes when new mail comes in (not compact related)

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
9 years ago
4 years ago

People

(Reporter: MarcoZ, Unassigned)

Tracking

({qawanted, regression})

Trunk
qawanted, regression
Bug Flags:
blocking-thunderbird3 -

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [regression: TB3])

(Reporter)

Description

9 years ago
Current Thunderbird 3.0 nightly build has a tendency to close the message reader window on me when new mail comes in. It's not 100% reproducible, but I see it several times a day when reading messages.

I have the message preview pane turned off and always open messages in a separate window for reading (pressing ENTER on a message in the messages list).

Related to this might be the following entry from error console:
Warning: Expected declaration but found '{'.  Skipped to next declaration.
Source File: imap://marco%2Ezehe%40googlemail%2Ecom@imap.googlemail.com:993/fetch%3EUID%3E/INBOX%3E113549
Line: 18

This started happening after I updated to a newer nightly after returning from the all-hands on May 2nd. Never seen it before that.
Flags: blocking-thunderbird3?
bienvenu, ideas?  that error log looks weird...

Comment 2

9 years ago
That warning looks like one of those css warnings I see from time to time - I suspect it's not related. The "source file" is just the URI we're running.

We do close the message window when we think the message has been deleted. I think there were some recent changes to make delete order in the message pane match the sort order. It's not the exact same code, but it's in the same area.
(Reporter)

Comment 3

9 years ago
Oh right! I do have one filter rule set up that deletes mail from a certain mailing list if its subject does not contain certain strings. However, the message I am currently reading is NOT being deleted, just closed.

Comment 4

9 years ago
The bug bienvenu talks about is bug 486954, landed 2009-04-18. 

Do you see it after deleting messages, or how do you move to next message?
If it's by delete, do you have mail.delete_matches_sort_order set? (That makes us move in the sorting direction when deleting a mail.)

Comment 5

9 years ago
I'm seeing this bug just viewing a message.  When I view the next message, I generally close the window and manually click on the next message, although occasionally I will delete in the floating window.  I'm sure I've seen this without a deletion; I'll open the window, flip to something else in another monitor, and watch the window email window disappear during an IMAP folder update.
It is unclear from comments 4 & 5 if this is still an issue or not. Therefore dropping back to unconfirmed to try and prompt re-confirmation.
Status: NEW → UNCONFIRMED
Ever confirmed: false
Keywords: qawanted
This bug is too hard to grasp to take a blocker, in its current state.
Flags: blocking-thunderbird3? → blocking-thunderbird3-

Comment 8

9 years ago
I'm seeing this on SeaMonkey 2.0b1 on Ubuntu Hardy (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1), using the tarball provided from the SeaMonkey web site.

I have the preview pane turned on, but sometimes I will open a message in a new window anyway.  Within a few minutes, the message will disappear, even if I don't do anything else in the mail window (and instead just use the browser).  This was not an issue in SeaMonkey 1.1.x.

The message I am viewing is not being deleted.  I do have message filters that process incoming messages and move some incoming messages to a subfolder.  This causes the original message that was opened in a separate window (which is _not_ being deleted or moved) to close.

I'm using SeaMonkey with IMAP to an Exchange server, in case that matters, since IMAP on Exchange doesn't seem to work as well as other IMAP servers.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 9

9 years ago
One other detail that may or may not be relevant:

My account settings include "When I delete a message, remove it immediately".  I don't know if this applies to messages that are moved to other folders by message filters.

Comment 10

9 years ago
Marco, can you identify/narrow the regression range?
Component: Mail Window Front End → Message Reader UI
QA Contact: front-end → message-reader

Comment 11

9 years ago
I just noticed that it's not specifically related to mail filters running.

If I open a message in my Inbox in a new window, and then move a different message from my Inbox into a subfolder, the original message in the new window closes.  (For what it's worth, I've now upgraded to Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2)
OS: Windows XP → All
Hardware: x86 → All
To bug opener and all problem reporters:

Do you enable auto-compact with mail.purge.ask=false? (call "silent auto-compact") 
If you do "silent auto-compact", it's possibly same phenomenon to Bug 518920 Comment #4 on Tb 3 nightly.
(Reporter)

Comment 13

9 years ago
(In reply to comment #12)
> Do you enable auto-compact with mail.purge.ask=false?

Nope, it's on its default setting of "true".

Comment 14

9 years ago
(In reply to comment #12)
> Do you enable auto-compact with mail.purge.ask=false? (call "silent
> auto-compact") 

It is also on the default setting of true for me.

Comment 15

6 years ago
(please reply)
Marco, Kevin, .... are you still seeing this in current versions, under the same circumstances (i.e. no compact)?

FWIW, the compact-related bug is Bug 520115
Summary: Message reader window sometimes closes when new mail comes in → Standalone Message reader window sometimes closes when new mail comes in (not compact related)
Whiteboard: [regression: TB3]
(Reporter)

Comment 16

4 years ago
Haven't seen this bug in ages. Closing as WFM.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.