Left frame shown incorrectly

VERIFIED INVALID

Status

()

P3
normal
VERIFIED INVALID
18 years ago
18 years ago

People

(Reporter: nh, Assigned: rickg)

Tracking

({testcase})

Trunk
x86
Windows 2000
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
The left side frame on this www location does not work.

http://mirror.aarnet.edu.au/pub/delphi/

Browser : Mozilla M18 Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18)
Gecko/20000813

Comment 1

18 years ago
*** Bug 49268 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
over to htmlframes
Assignee: asa → pollmann
Component: Browser-General → HTMLFrames
QA Contact: doronr → petersen

Comment 3

18 years ago
nh@pi.csiro.au I can't connect to the url. Can you upload a testcase or post 
another functioning url that shows the bug?

Comment 4

18 years ago
The US mirror for the site is http://delphi.icm.edu.pl/. The page loads fine if 
you remove the html4.0 doctype. The w3c html validator spews pages of errors 
when it checks the code, so this looks invalid to me.
Summary: Frames show incorrectly → Left frame shown incorrectly

Comment 5

18 years ago
Created attachment 13165 [details]
html file of the left frame that's not loading. remove the doctype & it loads

Comment 6

18 years ago
Created attachment 13203 [details]
Testcase

Comment 7

18 years ago
The problem is indeed strict parsing of invalid content. The <BODY> content
starts with <IMG> which is not a block element. Reassigning to Parser.
Assignee: pollmann → rickg
Component: HTMLFrames → Parser
Keywords: testcase
QA Contact: petersen → janc

Comment 8

18 years ago
confirmed witn 082208 mozilla win32 build
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

18 years ago
Wont fix this for a few reasons: 1) it's illegal markup. 2) it's strict, and 
we're removing strict support.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID

Comment 10

18 years ago
Source code problem not ours. Marking as verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.