404 pages broken, possibly busting Fx3.0 debug builders

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
10 years ago
6 years ago

People

(Reporter: nthomas, Assigned: reed)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
$ curl -I http://www.mozilla.org/projects/firefox/3.0.11pre/whatsnew/
 HTTP/1.1 500 Internal Server Error

Firefox just displays an empty page, but I think it causes problems to our debug builds of Fx3.0.x,
 http://tinderbox.mozilla.org/showbuilds.cgi?tree=Firefox3.0

Windows builds from 2009/05/12 23:49 PDT (on WINNT 5.2 fxdbug-win32-tb Dep Debug + Leak Test), and Mac builds from 2009/05/13 00:10 PDT (on MacOSX Darwin 8.8.4 bm-xserve11 Dep Debug + Leak Test), hit an assertion:

###!!! ASSERTION: unexpected progress values: 'progress <= progressMax', file e:/builds/tinderbox/Fx-Trunk-Memtest/WINNT_5.2_Depend/mozilla/netwerk/protocol/http/src/nsHttpChannel.cpp, line 4587

while executing "firefox -P default" on a new profile. IIRC the browser is trying to load the whatsnew url in that situation. See http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.0/1242197340.1242198927.7836.gz

We can rule out code change on CVS (last was 2009/05/07) and the outage affecting the build machines (the windows box was off but mac is real hardware and hits this too). It's possible there is something odd in the mozilla.org server(s), but also CCing fantasai because her checking at 2009-05-12 15:01 to mozilla-org/html/404.html seems strongly related.
(Reporter)

Comment 1

10 years ago
FWIW, we're not hitting this on Linux 3.0, or any platform for 3.5 or 3.6.

Updated

10 years ago
Depends on: 453475
Reed, fantasai: Why is that page a weird 404/500 mix after your work yesterday?
(Assignee)

Comment 3

10 years ago
missing.pl lost its +x again. I added a temp fix... need to hack the tools to do it for me. Change is being synched out now.
Assignee: nobody → reed
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Hardware: x86 → All
Resolution: --- → FIXED
Summary: whatsnew pages broken, possibly busting Fx3.0 debug builders → 404 pages broken, possibly busting Fx3.0 debug builders
(Assignee)

Updated

10 years ago
Duplicate of this bug: 492738
Everything works now as expected. thanks.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

10 years ago
Fx3.0 machines are happy too, thanks.
Hardware: All → x86
(Reporter)

Comment 7

10 years ago
Reed, do you want to reopen this to "Really Fix It (tm)" or handle elsewhere ?
(Assignee)

Comment 8

10 years ago
(In reply to comment #7)
> Reed, do you want to reopen this to "Really Fix It (tm)" or handle elsewhere ?

New bug, please. I'll try to get to it within the next day or so.
(Reporter)

Comment 9

10 years ago
See bug 495899.
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.