-moz-win-glass has effect on Content wrongfully

VERIFIED DUPLICATE of bug 458407

Status

()

Core
Widget: Win32
VERIFIED DUPLICATE of bug 458407
9 years ago
9 years ago

People

(Reporter: pirlouy, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b5pre) Gecko/20090510 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.1b5pre) Gecko/20090510 Shiretoko/3.5b5pre (.NET CLR 3.5.30729)

Firefox 3.5 introduces a new CSS property: -moz-win-glass , but it has some problems.

If you use this code in UserChrome.css:

#main-window[windowtype="navigator:browser"] {
    background: transparent !important;
    -moz-appearance: -moz-win-glass !important;}

toolbox, .tabbrowser-tabs  {
    background-color: transparent !important;
    background-image: none !important;
    -moz-appearance: none !important; }

You should have Aero effect. But there's a problem: it also affects page Content.
Screenshot of problem here (1075 x 1024, 185kb) : http://img149.imageshack.us/img149/2371/090508sevenfirefoxblur2.png

Text instead of been black is like transparent.

I'm sorry for vocabulary but it's hard to explain. I think the ones who have implemented -moz-win-glass should understand.

Reproducible: Always

Updated

9 years ago
Component: General → Widget: Win32
Product: Firefox → Core
QA Contact: general → win32

Updated

9 years ago
Blocks: 431646
(Reporter)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 458407

Updated

9 years ago
No longer blocks: 431646

Updated

9 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.