Prevent developers from removing all application compatibility ranges from an add-on version

RESOLVED FIXED

Status

RESOLVED FIXED
10 years ago
3 years ago

People

(Reporter: Gijs, Assigned: rjwalsh)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
STR:

1. Open nomination queue ( https://addons.mozilla.org/en-US/firefox/editors/queue/nominated )
2. Look at the row for "GMail Improved 0.9.7" (install.rdf is here: https://addons.mozilla.org/en-US/firefox/files/browse/42193/1 )


ER: Shows Firefox logo
AR: No logo whatsoever

The actual add-on page ( https://addons.mozilla.org/en-US/firefox/addon/9007 ) does show an "Add to Firefox" button, so it seems to work fine otherwise...
(Reporter)

Comment 1

10 years ago
New STR:

1. Pick your favourite add-on that you're developing and has at least 2 AMO
versions.

2. Open the oldest version page.
3. Write down the version compatibility ranges you have selected for it.
4. Remove all of them.
5. Click "Update"

Expected:
"Error: any version of your add-on needs to have at least one compatible
application and associated version range. Please re-add at least one version
range."

Actual:
"Your changes have been saved."
Severity: minor → normal
Component: Admin/Editor Tools → Developer Pages
QA Contact: admin-tools → developers
Summary: Sometimes (Greasemonkey-compiler-generated install.rdf?) compatibility with Firefox not shown in queue → Prevent developers from removing all application compatibility ranges from an add-on version
(Assignee)

Comment 2

9 years ago
Created attachment 397128 [details] [diff] [review]
Fix
Assignee: nobody → rjbuild1088
Attachment #397128 - Flags: review?(clouserw)
Attachment #397128 - Flags: review?(clouserw) → review+
(Assignee)

Comment 3

9 years ago
Fixed in r51312
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.