If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Firefox does not honor gfx.color_management.mode 2 flag!

RESOLVED FIXED

Status

()

Core
GFX: Color Management
RESOLVED FIXED
9 years ago
7 years ago

People

(Reporter: Kostas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10 (.NET CLR 3.5.30729)

I recently was stumbled after calibrating my monitor, I am using firefox 3.0.10 and safari 4.
To be more precise many of pictures of known photographer would appear wrong to my monitor through firefox but would render correctly under safari.
After some checking I managed to see that this is happening to non tagged images I receive and oversaturated version of the images, as if it was translated to sRGB and THEN to my monitor profile.
To be more precise:
http://www.naturefocused.com/articles/softproofingforweb.php
The first set of images comparing the problem (and discussing it regarding safari browser) appears both the same on mozilla firefox, but as it should be under safari (check attached screenshots).
Another example can be seen with this picture (as well untagged):
http://www.michaelandersongallery.com/photo.php?id=96&gallery=himalayas
On my firefox browser the blue shifts to purple while on safari it remains as blue.
To perform an even better test I downloaded the image and opened it inside photoshop, assigning an sRGB profile to it did provide the oversaturated look (blues turning to purple) while when I assigned the monitor profile to it I could see the blues normal.
I can confirm this behavior also when I switch the gfx.color_management.mode flag to 2 or to 1.
Image in non color managed browser (IE) appears without the purple shift as well.


Reproducible: Always

Steps to Reproduce:
1. enable color management (monitor hardware calibrated)
2. visit http://www.naturefocused.com/articles/softproofingforweb.php
3. look at the first set of pictures, they should be different but on firefox they render the same!
Additionally:
Visiting:
http://www.michaelandersongallery.com/photo.php?id=96&gallery=himalayas
Should render the sky in a deep blue color, in firefox it renders as purple, safari (color managed) and IE (non color managed) render the picture as blue.
Downloading the picture and opening it inside photoshop and assigning the monitor profile to it renders correctly.
Actual Results:  
Color mismatch between color managed browsers

Expected Results:  
Should render the picture according to the monitor profile.
(Reporter)

Comment 1

9 years ago
Created attachment 377200 [details]
Firefox color management

As you can see (I hope so) this is the output from my 2 browsers, the left one is firefox the right one is safari.
(Reporter)

Comment 2

9 years ago
I am sorry I took a better look under color management and I think we can narrow this, its actually a gfx.color_management.mode issue! (unless I have understood wrongly).
I have set the flag to the above option to 2 which means render only tagged images, this is not the case though in my situation, since firefox renders also untagged images with the monitor profile (while safari for windows does not!).
In the posted examples above you can see the difference, on the purple set of images (which the one should be rendered blue) firefox rendered both images, ignoring the fact that the one (which was correctly rendered under safari) is missing an ICC tag.
(Reporter)

Updated

9 years ago
Summary: Color management does not Honor color profile correctly → Firefox does not honor gfx.color_management.mode 2 flag!
(Reporter)

Comment 3

9 years ago
Uninstalling firefox 3.5b4 removes the gfx.color_management.mode so I assume 3.0.10 does not support this?
Component: General → GFX: Color Management
Product: Firefox → Core
QA Contact: general → color-management
reassigned to color management component.

Jeff - do you think this might be related to bug 492962?
(Reporter)

Comment 5

9 years ago
I believe it is Bobby.
(Reporter)

Comment 6

9 years ago
Bobby, I installed firefox 3.1b3 and now untagged images are rendered as sRGB non color managed (I believe the way it should be), tagged images are rendered with the monitor profile.
This seems fixed
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.