On high level folder, 'Empty Junk' context option deletes *everything* under that folder

RESOLVED INVALID

Status

Thunderbird
Folder and Message Lists
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: Richard Patchet, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4) Gecko/20090423 Firefox/3.5b4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

I have a 'Local Folders' folder under which I have numerous subfolders. I right-clicked on 'Local Folders' and selected the option to 'Empty Junk'. Thunderbird deleted the Mail directory in the profile directory of the user (e.g. C:\Documents and Settings\Computer Owner\Application Data\Thunderbird\Profiles\3b0ngwgx.default\Mail). After rebuilding the directory, a subsequent test of the same bug eliminated all the folders in the Thunderbird pane but did not delete the Mail directory on disk.

Reproducible: Always

Steps to Reproduce:
1. Right-click on 'Local Folders'
2. Click on 'Empty Junk'
3. Cry when all your saved emails disappear
Actual Results:  
Thunderbird deleted the Mail directory in the profile.

Expected Results:  
Thunderbird will empty the Junk folder.

Comment 1

9 years ago
When I try this, I cannot select "Empty Junk" because it is does not appear when I right-click Local Folders. (I am running current 3.0b3pre)

Is there some trick to getting the "Empty Junk" to appear with the right click?
Could have been a bug where we displayed the option (and shouldn't have) which we have fixed since beta 2. cc'ing some people who may know.

Comment 3

9 years ago
I had Beta2 build 2 on my system ( which was slightly prerelease) and it also did not show the option.

Comment 4

9 years ago
Don't recall any bug for this, my best guess is some extension problem...
Richard, please try with all extensions disabled.

Also try a build from http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-1.9.1/ as the context menu show/hide logic was pretty much rewritten (to handle multi) select last week.
(Reporter)

Comment 5

9 years ago
My apologies. I did not remember ever having added any extensions in Thunderbird. It was Mail Tweak. I removed it and the context option went away.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.