Memory leak when cache is disabled

RESOLVED INVALID

Status

()

Firefox
General
--
major
RESOLVED INVALID
9 years ago
9 years ago

People

(Reporter: info, Unassigned)

Tracking

3.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caused by web developer toolbar?])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10

If you have installed Web Developer Toolbar and disable the cache you get a memory leak. Each time you reload a webpage, the allocated memory of firefox increases. After a while RAM is bloated with leaked data and Windows starts swapping to disk. This makes it a pain to surf with firefox

Reproducible: Always

Steps to Reproduce:
1. install web developer toolbar
2. disable cache in web developer toolbar
3. reload a big website like yahoo.com


Expected Results:  
memory amount allocated by firefox should be the same as before the reload.

this bug can behave different on faster computers.
on older computers (Pentium 4, etc.) this can be more severe.
(Reporter)

Updated

9 years ago
Version: unspecified → 3.0 Branch

Comment 1

9 years ago
firefox uses a memory management technique called "garbage collection" in some areas of the code so memory might not be restored immediately.

there is more information here on how to narrow down the problem you are seeing.

leaks can also be the result of addons so one step would be do disable the addon, then disable the cache in firefox, then try the same test steps.
I think something like this, which seems related to the web developer toolbar, would be their bug, and should be reported to them. It could be our fault, but not from the evidence. Please talk to them. Chris, what link were you trying to post? Maybe,http://quality.mozilla.org/bug-writing-guidelines#memory?
Severity: critical → major
No reply, seems to be an extension issue. Reporter, please reopen this bug if you can see this issue with Firefox 3.5 or later in Firefox Safe Mode (http://support.mozilla.com/kb/Safe+Mode) or a new profile (http://support.mozilla.com/kb/Profiles)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
Whiteboard: [caused by web developer toolbar?]
You need to log in before you can comment on or make changes to this bug.