All users were logged out of Bugzilla on October 13th, 2018

vcs update does not work

RESOLVED FIXED in 0.4.2

Status

P2
major
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: dangoor, Assigned: dangoor)

Tracking

0.2.2
0.4.2

Details

(Assignee)

Description

10 years ago
Reported by JuanPablo on the mailing list:

I clone
vcs clone ssh://hg@bitbucket.org/my_repository

and in other pc clone, make changes, commit and push
> hg commit -m "new changes ..."
> hg push
... ok

now, if try update in bespin ...
> vcs update
...

get this output
"
vcs update output

hg fetch: invalid arguments
hg fetch [SOURCE]

pull changes from a remote rep ....
"


- note from Kevin:
I can reproduce this on bespin.mozilla.com. I don't know for sure what is being 
passed to "hg fetch", but it looks like it *should* be working.
Moving to new Version Control component.
Component: Server → Version Control
OS: Mac OS X → All
QA Contact: server → version.control
Hardware: x86 → All
(Assignee)

Comment 2

9 years ago
I can confirm that vcs update is working fine in db45fe1a687d
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → 0.3.0

Comment 3

9 years ago
I can reproduce this bug in 0.4.1
(Assignee)

Comment 4

9 years ago
Reopening for investigation
Status: RESOLVED → REOPENED
Priority: -- → P2
Resolution: FIXED → ---
Target Milestone: 0.3.0 → 0.4.2
(Assignee)

Comment 5

9 years ago
The problem here is that "hg fetch" has two -e options! ugh.

I changed uvc to use --ssh, and that appears to fix this problem.

This fix is in uvc 0.4.1.
Status: REOPENED → RESOLVED
Last Resolved: 9 years ago9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.